SilverStripe 4.5.0 allows attackers to read certain records that should not have been…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
SilverStripe 4.5.0 allows attackers to read certain records that should not have been placed into a result set. This affects silverstripe/recipe-cms. The automatic permission-checking mechanism in the silverstripe/graphql module does not provide complete protection against lists that are limited (e.g., through pagination), resulting in records that should have failed a permission check being added to the final result set. GraphQL endpoints are configured by default (e.g., for assets), but the admin/graphql endpoint is access protected by default. This limits the vulnerability to all authenticated users, including those with limited permissions (e.g., where viewing records exposed through admin/graphql requires administrator permissions). However, if custom GraphQL endpoints have been configured for a specific implementation (usually under /graphql), this vulnerability could also be exploited through unauthenticated requests. This vulnerability only applies to reading records; it does not allow unauthorised changing of records.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | silverstripe/recipe-cms (Packagist) | 4.5.0 to before 4.5.3 | 4.5.3 | Patch available | GHSA-589q-75r3-mfq4 |
| — | silverstripe/graphql (Packagist) | 3.2.0 to before 3.2.4 | 3.2.4 | Patch available | GHSA-589q-75r3-mfq4 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- silverstripe/recipe-cms (Packagist) Vendor— Affected 4.5.0 to before 4.5.3 Fixed in 4.5.3 Patch available GHSA-589q-75r3-mfq4
- silverstripe/graphql (Packagist) Vendor— Affected 3.2.0 to before 3.2.4 Fixed in 3.2.4 Patch available GHSA-589q-75r3-mfq4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:silverstripe:silverstripe:*:*:*:*:*:*:*:* | 3.2.0 to before 3.2.4; 3.2.5 to before 3.3.0; 4.5.0 to before 4.5.3 | Vulnerable | silverstripe |
- cpe:2.3:a:silverstripe:silverstripe:*:*:*:*:*:*:*:* Versions 3.2.0 to before 3.2.4; 3.2.5 to before 3.3.0; 4.5.0 to before 4.5.3 Vulnerable ·silverstripe
Remediation
- Fix · GHSA-589q-75r3-mfq4 silverstripe/recipe-cms (Packagist) Fixed in 4.5.3 Advisory →
- Fix · GHSA-589q-75r3-mfq4 silverstripe/graphql (Packagist) Fixed in 3.2.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-6165
- 2026-10-03 Alias added: GHSA-589q-75r3-mfq4
References
Advisory 2
Other 3
- https://docs.silverstripe.org/en/4/changelogs/4.5.3/?_ga=2.170693920.105499209.1689776417-708940272.1689776417
- https://docs.silverstripe.org/en/4/changelogs/4.6.0/?_ga=2.170693920.105499209.1689776417-708940272.1689776417
- https://github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/graphql/CVE-2020-6165.yaml
More Silverstripe vulnerabilities
- TI-2007-02239 Unspecified vulnerability in the search functionality in SilverStripe 2.0.0 has unknown impact and attack vectors. CVSS 2.0HIGH 10.0
- TI-2019-09110 In SilverStripe through 4.3.3, a missing warning about leaving install.php in a public… CVSS 3.1CRITICAL 9.8
- TI-2019-04049 All versions of SilverStripe 3 prior to 3.6.7 and 3.7.3, and all versions of SilverStripe… CVSS 3.0CRITICAL 9.8
- TI-2019-09281 In SilverStripe through 4.3.3, the previous fix for SS-2018-007 does not completely… CVSS 3.1HIGH 8.8
- TI-2011-04272 code/sitefeatures/PageCommentInterface.php in SilverStripe 2.4.x before 2.4.6 might allow… CVSS 2.0MEDIUM 6.8
- TI-2020-07421 In SilverStripe through 4.5, files uploaded via Forms to folders migrated from… CVSS 3.1HIGH 7.5
Sources
- CVE-2020-6165 · CVE Program
- CVE-2020-6165 · NVD
- FIRST EPSS
- GHSA-589q-75r3-mfq4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences