Improper privilege management in Elasticsearch
Priority MEDIUM 42CWE-266Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-266.
Summary
Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.
Why it matters now
EPSS 0.01881 79th percentileScored 2026-11-07
Fix Fixed org.elasticsearch:elasticsearch (Maven): 6.8.8, 7.6.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elastic | Elasticsearch | All versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 | — | No fix listed | CNA |
| — | org.elasticsearch:elasticsearch (Maven) | 6.7.0 to before 6.8.8 | 6.8.8 | Patch available | GHSA-gfv5-grx2-9jw2 |
| — | org.elasticsearch:elasticsearch (Maven) | 7.0.0 to before 7.6.2 | 7.6.2 | Patch available | GHSA-gfv5-grx2-9jw2 |
- Elasticsearch VendorElastic Affected All versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 Fixed in — No fix listed CNA
- org.elasticsearch:elasticsearch (Maven) Vendor— Affected 6.7.0 to before 6.8.8 Fixed in 6.8.8 Patch available GHSA-gfv5-grx2-9jw2
- org.elasticsearch:elasticsearch (Maven) Vendor— Affected 7.0.0 to before 7.6.2 Fixed in 7.6.2 Patch available GHSA-gfv5-grx2-9jw2
Remediation
- Fix · GHSA-gfv5-grx2-9jw2 org.elasticsearch:elasticsearch (Maven) Fixed in 6.8.8 Advisory →
- Fix · GHSA-gfv5-grx2-9jw2 org.elasticsearch:elasticsearch (Maven) Fixed in 7.6.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 6 products
- Red Hat Decision Manager 7
- Red Hat Fuse 7
- Red Hat JBoss Fuse 6
- Red Hat OpenShift Container Platform 3.11
- Red Hat OpenShift Container Platform 4
- Red Hat Process Automation 7
Timeline
- 2026-10-02 Threatist record created from CVE-2020-7009
- 2026-10-03 Alias added: GHSA-gfv5-grx2-9jw2
References
Advisory 4
More Elasticsearch vulnerabilities
- TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
- TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
- TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
- TI-2021-05136 All versions of Elastic Cloud Enterprise has the Elasticsearch “anonymous” user enabled… CVSS 3.1HIGH 7.5
- TI-2015-04530 Elasticsearch before 1.6.1 allows remote attackers to execute arbitrary code via… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2020-7009 · CVE Program
- CVE-2020-7009 · NVD
- FIRST EPSS
- GHSA-gfv5-grx2-9jw2 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-7009 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences