Read the docs
TI-2020-05668 Aliases CVE-2020-7020GHSA-g9fw-9x87-rmrj

Improper privilege management in Elasticsearch

Priority LOW 17CWE-270Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
High
Impact type
Privilege escalation
Confidentiality · integrity · availability
Low · None · None
Fix status
Partial Red Hat: 1 fixed, 3 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-269.

Summary

Elasticsearch versions before 6.8.13 and 7.9.2 contain a document disclosure flaw when Document or Field Level Security is used. Search queries do not properly preserve security permissions when executing certain complex queries. This could result in the search disclosing the existence of documents the attacker should not be able to view. This could result in an attacker gaining additional insight into potentially sensitive indices.

Why it matters now

EPSS 0.01085 65th percentileScored 2026-11-07
Fix Partial org.elasticsearch:elasticsearch (Maven): 6.8.13, 7.9.2Red Hat: 1 advisoryRed Hat: 1 fixed, 3 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ElasticElasticsearchbefore 6.8.13 and 7.9.2—No fix listedCNA
—org.elasticsearch:elasticsearch (Maven)before 6.8.136.8.13Patch availableGHSA-g9fw-9x87-rmrj
—org.elasticsearch:elasticsearch (Maven)7.0.0 to before 7.9.27.9.2Patch availableGHSA-g9fw-9x87-rmrj
  • Elasticsearch VendorElastic Affected before 6.8.13 and 7.9.2 Fixed in — No fix listed CNA
  • org.elasticsearch:elasticsearch (Maven) Vendor— Affected before 6.8.13 Fixed in 6.8.13 Patch available GHSA-g9fw-9x87-rmrj
  • org.elasticsearch:elasticsearch (Maven) Vendor— Affected 7.0.0 to before 7.9.2 Fixed in 7.9.2 Patch available GHSA-g9fw-9x87-rmrj

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:elastic:elasticsearch:*:*:*:*:*:*:*:*before 6.8.13; 7.0.0 to before 7.9.2VulnerableElastic
  • cpe:2.3:a:elastic:elasticsearch:*:*:*:*:*:*:*:* Versions before 6.8.13; 7.0.0 to before 7.9.2 Vulnerable ·Elastic

Remediation

  • Fix · GHSA-g9fw-9x87-rmrj org.elasticsearch:elasticsearch (Maven) Fixed in 6.8.13 Advisory →
  • Fix · GHSA-g9fw-9x87-rmrj org.elasticsearch:elasticsearch (Maven) Fixed in 7.9.2 Advisory →

Red Hat 1 advisory

  • RHSA-2022:5532 Released 2022-07-07 · Red Hat rating Important
    Red Hat Fuse 7.11.0 release and security update
    • Red Hat Fuse 7.11

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Decision Manager 7AffectedNo fix yet: Fix deferred
Red Hat JBoss Fuse 6AffectedNo fix planned: Out of support scope
Red Hat Process Automation 7AffectedNo fix yet: Fix deferred
Red Hat Fuse 7.11Fixed RHSA-2022:5532
Not affected: 2 products
  • Red Hat OpenShift Container Platform 3.11
  • Red Hat OpenShift Container Platform 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-7020
  2. 2026-10-03 Alias added: GHSA-g9fw-9x87-rmrj

References

  • TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
  • TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
  • TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
  • TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
  • TI-2021-05136 All versions of Elastic Cloud Enterprise has the Elasticsearch “anonymous” user enabled… CVSS 3.1HIGH 7.5
  • TI-2015-04530 Elasticsearch before 1.6.1 allows remote attackers to execute arbitrary code via… CVSS 3.0CRITICAL 9.8
See all 90 →

Sources