Files added to tar with Phar::buildFromIterator have all-access permissions
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 5 fixed, 5 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
In PHP versions 7.2.x below 7.2.28, 7.3.x below 7.3.15 and 7.4.x below 7.4.3, when creating PHAR archive using PharData::buildFromIterator() function, the files are added with default permissions (0666, or all access) even if the original files on the filesystem were with more restrictive permissions. This may result in files having more lax permissions than intended when such archive is extracted.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PHP Group | PHP | 7.3.x to before 7.3.15; 7.4.x to before 7.4.3; 7.2.x to before 7.2.28 | 7.3.15, 7.4.3, 7.2.28 | Patch available | CNA |
- PHP VendorPHP Group Affected 7.3.x to before 7.3.15; 7.4.x to before 7.4.3; 7.2.x to before 7.2.28 Fixed in 7.3.15, 7.4.3, 7.2.28 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:php:php:*:*:*:*:*:*:*:* | 7.2.0 – 7.2.27; 7.3.0 – 7.3.14; 7.4.0 – 7.4.2 | Vulnerable | PHP |
| cpe:2.3:a:tenable:tenable.sc:*:*:*:*:*:*:*:* | before 5.19.0 | Vulnerable | Tenable |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
- cpe:2.3:a:php:php:*:*:*:*:*:*:*:* Versions 7.2.0 – 7.2.27; 7.3.0 – 7.3.14; 7.4.0 – 7.4.2 Vulnerable ·PHP
- cpe:2.3:a:tenable:tenable.sc:*:*:*:*:*:*:*:* Versions before 5.19.0 Vulnerable ·Tenable
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
Remediation
- Fix · CNA PHP (PHP Group) Fixed in 7.3.15, 7.4.3, 7.2.28
Red Hat 2 advisories
- RHSA-2020:5275 Released 2020-12-01 · Red Hat rating Moderaterh-php73-php security, bug fix, and enhancement update
- Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) rh-php73-php-7.3.20-1.el7, rh-php73-php-bcmath-7.3.20-1.el7, rh-php73-php-cli-7.3.20-1.el7 +26
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.6) rh-php73-php-7.3.20-1.el7, rh-php73-php-bcmath-7.3.20-1.el7, rh-php73-php-cli-7.3.20-1.el7 +26
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7) rh-php73-php-7.3.20-1.el7, rh-php73-php-bcmath-7.3.20-1.el7, rh-php73-php-cli-7.3.20-1.el7 +26
- Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) rh-php73-php-7.3.20-1.el7, rh-php73-php-bcmath-7.3.20-1.el7, rh-php73-php-cli-7.3.20-1.el7 +26
- RHSA-2020:3662 Released 2020-09-08 · Red Hat rating Moderatephp:7.3 security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream (v. 8) apcu-panel-5.1.17-1.module+el8.1.0+3189+a1bff096.noarch::php:7.3, libzip-1.5.2-1.module+el8.1.0+3189+a1bff096.aarch64::php:7.3, libzip-1.5.2-1.module+el8.1.0+3189+a1bff096.ppc64le::php:7.3 +47
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
PHP 7.2.28, 7.3.15, 7.4.3
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2020-05701 Null Pointer Dereference in PHP Session Upload ProgressPriority LOW 39
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Will not fix |
| Red Hat Software Collections | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2020:3662 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2020:5275 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.6) | Fixed | RHSA-2020:5275 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7) | Fixed | RHSA-2020:5275 |
| Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2020:5275 |
Timeline
- 2026-10-02 Threatist record created from CVE-2020-7063
- 2026-10-03 Alias added: GHSA-rm3c-r6h9-r9rg
References
More PHP Group vulnerabilities
- TI-2024-04260 Argument Injection in PHP-CGI KEVCVSS 3.1CRITICAL 9.8
- TI-2026-78794 PHP remote code execution via stale global state KEVCVSS 4.0CRITICAL 9.2
- TI-2026-78793 Out-of-memory handling flaw in PHP allows remote code execution KEVCVSS 4.0CRITICAL 9.2
- TI-2024-01743 Command injection via array-ish $command parameter of proc_open() CVSS 3.1CRITICAL 9.4
- TI-2022-13555 PDO::quote() may return unquoted string CVSS 3.1CRITICAL 9.1
- TI-2024-10408 Reference counting in php_request_shutdown causes Use-After-Free CVSS 4.0CRITICAL 9.2
Sources
- CVE-2020-7063 · CVE Program
- CVE-2020-7063 · NVD
- FIRST EPSS
- GHSA-rm3c-r6h9-r9rg · GitHub Advisory Database · CC BY 4.0
- CVE-2020-7063 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences