mb_strtolower (UTF-32LE): stack-buffer-overflow at php_unicode_tolower_full
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-121 and the CVSS impact.
Summary
In PHP versions 7.3.x below 7.3.16 and 7.4.x below 7.4.4, while using mb_strtolower() function with UTF-32LE encoding, certain invalid strings could cause PHP to overwrite stack-allocated buffer. This could lead to memory corruption, crashes and potentially code execution.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PHP Group | PHP | 7.3.x to before 7.3.16; 7.4.x to before 7.4.4 | 7.3.16, 7.4.4 | Patch available | CNA |
- PHP VendorPHP Group Affected 7.3.x to before 7.3.16; 7.4.x to before 7.4.4 Fixed in 7.3.16, 7.4.4 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:php:php:*:*:*:*:*:*:*:* | 7.3.0 to before 7.3.16; 7.4.0 to before 7.4.4 | Vulnerable | PHP |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:esm:*:*:* | 12.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:esm:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:* | 19.10 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* | 20.04 | Vulnerable | Canonical |
| cpe:2.3:a:tenable:tenable.sc:*:*:*:*:*:*:*:* | before 5.19.0 | Vulnerable | Tenable |
- cpe:2.3:a:php:php:*:*:*:*:*:*:*:* Versions 7.3.0 to before 7.3.16; 7.4.0 to before 7.4.4 Vulnerable ·PHP
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:esm:*:*:* Versions 12.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:esm:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:* Versions 19.10 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* Versions 20.04 Vulnerable ·Canonical
- cpe:2.3:a:tenable:tenable.sc:*:*:*:*:*:*:*:* Versions before 5.19.0 Vulnerable ·Tenable
Remediation
- Fix · CNA PHP (PHP Group) Fixed in 7.3.16, 7.4.4
Red Hat 2 advisories
- RHSA-2020:5275 Released 2020-12-01 · Red Hat rating Moderaterh-php73-php security, bug fix, and enhancement update
- Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) rh-php73-php-7.3.20-1.el7, rh-php73-php-bcmath-7.3.20-1.el7, rh-php73-php-cli-7.3.20-1.el7 +26
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.6) rh-php73-php-7.3.20-1.el7, rh-php73-php-bcmath-7.3.20-1.el7, rh-php73-php-cli-7.3.20-1.el7 +26
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7) rh-php73-php-7.3.20-1.el7, rh-php73-php-bcmath-7.3.20-1.el7, rh-php73-php-cli-7.3.20-1.el7 +26
- Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) rh-php73-php-7.3.20-1.el7, rh-php73-php-bcmath-7.3.20-1.el7, rh-php73-php-cli-7.3.20-1.el7 +26
- RHSA-2020:3662 Released 2020-09-08 · Red Hat rating Moderatephp:7.3 security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream (v. 8) apcu-panel-5.1.17-1.module+el8.1.0+3189+a1bff096.noarch::php:7.3, libzip-1.5.2-1.module+el8.1.0+3189+a1bff096.aarch64::php:7.3, libzip-1.5.2-1.module+el8.1.0+3189+a1bff096.ppc64le::php:7.3 +47
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
PHP — USN-4330-2
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2020-05703 Use-of-uninitialized-value in exifPriority LOW 36
- TI-2020-05705 get_headers() silently truncates after a null bytePriority LOW 29
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2020:3662 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2020:5275 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.6) | Fixed | RHSA-2020:5275 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7) | Fixed | RHSA-2020:5275 |
| Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2020:5275 |
Not affected: 5 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Software Collections
Timeline
- 2026-10-02 Threatist record created from CVE-2020-7065
- 2026-10-03 Alias added: GHSA-hpqg-gp78-43q4
References
More PHP Group vulnerabilities
- TI-2024-04260 Argument Injection in PHP-CGI KEVCVSS 3.1CRITICAL 9.8
- TI-2026-78794 PHP remote code execution via stale global state KEVCVSS 4.0CRITICAL 9.2
- TI-2026-78793 Out-of-memory handling flaw in PHP allows remote code execution KEVCVSS 4.0CRITICAL 9.2
- TI-2024-01743 Command injection via array-ish $command parameter of proc_open() CVSS 3.1CRITICAL 9.4
- TI-2022-13555 PDO::quote() may return unquoted string CVSS 3.1CRITICAL 9.1
- TI-2024-10408 Reference counting in php_request_shutdown causes Use-After-Free CVSS 4.0CRITICAL 9.2
Sources
- CVE-2020-7065 · CVE Program
- CVE-2020-7065 · NVD
- FIRST EPSS
- GHSA-hpqg-gp78-43q4 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-7065 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences