FILTER_VALIDATE_URL accepts URLs with invalid userinfo
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 4 fixed, 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
In PHP versions 7.3.x below 7.3.26, 7.4.x below 7.4.14 and 8.0.0, when validating URL with functions like filter_var($url, FILTER_VALIDATE_URL), PHP will accept an URL with invalid password as valid URL. This may lead to functions that rely on URL being valid to mis-parse the URL and produce wrong data as components of the URL.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PHP Group | PHP | 7.3.x to before 7.3.26; 7.4.x to before 7.4.14; 8.0.X to before 8.0.1 | 7.3.26, 7.4.14, 8.0.1 | Patch available | CNA |
- PHP VendorPHP Group Affected 7.3.x to before 7.3.26; 7.4.x to before 7.4.14; 8.0.X to before 8.0.1 Fixed in 7.3.26, 7.4.14, 8.0.1 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:php:php:*:*:*:*:*:*:*:* | 7.3.0 to before 7.3.26; 7.4.0 to before 7.4.14; 8.0.0 to before 8.0.1 | Vulnerable | PHP |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:a:netapp:clustered_data_ontap:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
- cpe:2.3:a:php:php:*:*:*:*:*:*:*:* Versions 7.3.0 to before 7.3.26; 7.4.0 to before 7.4.14; 8.0.0 to before 8.0.1 Vulnerable ·PHP
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:a:netapp:clustered_data_ontap:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
Remediation
- Fix · CNA PHP (PHP Group) Fixed in 7.3.26, 7.4.14, 8.0.1
Red Hat 2 advisories
- RHSA-2021:4213 Released 2021-11-09 · Red Hat rating Moderatephp:7.4 security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream (v. 8) apcu-panel-5.1.18-1.module+el8.3.0+6678+b09f589e.noarch::php:7.4, libzip-1.6.1-1.module+el8.3.0+6678+b09f589e.aarch64::php:7.4, libzip-1.6.1-1.module+el8.3.0+6678+b09f589e.ppc64le::php:7.4 +47
- RHSA-2021:2992 Released 2021-08-03 · Red Hat rating Moderaterh-php73-php security, bug fix, and enhancement update
- Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) rh-php73-php-7.3.29-1.el7, rh-php73-php-bcmath-7.3.29-1.el7, rh-php73-php-cli-7.3.29-1.el7 +26
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7) rh-php73-php-7.3.29-1.el7, rh-php73-php-bcmath-7.3.29-1.el7, rh-php73-php-cli-7.3.29-1.el7 +26
- Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) rh-php73-php-7.3.29-1.el7, rh-php73-php-bcmath-7.3.29-1.el7, rh-php73-php-cli-7.3.29-1.el7 +26
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
PHP — GLSA-202105-23
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2021-04782 Null Dereference in SoapClientPriority LOW 39
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2021:4213 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2021:2992 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7) | Fixed | RHSA-2021:2992 |
| Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2021:2992 |
Not affected: 1 product
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2020-7071
- 2026-10-03 Alias added: GHSA-grxx-qh3p-vx7g
References
More PHP Group vulnerabilities
- TI-2024-04260 Argument Injection in PHP-CGI KEVCVSS 3.1CRITICAL 9.8
- TI-2026-78794 PHP remote code execution via stale global state KEVCVSS 4.0CRITICAL 9.2
- TI-2026-78793 Out-of-memory handling flaw in PHP allows remote code execution KEVCVSS 4.0CRITICAL 9.2
- TI-2024-01743 Command injection via array-ish $command parameter of proc_open() CVSS 3.1CRITICAL 9.4
- TI-2022-13555 PDO::quote() may return unquoted string CVSS 3.1CRITICAL 9.1
- TI-2024-10408 Reference counting in php_request_shutdown causes Use-After-Free CVSS 4.0CRITICAL 9.2
Sources
- CVE-2020-7071 · CVE Program
- CVE-2020-7071 · NVD
- FIRST EPSS
- GHSA-grxx-qh3p-vx7g · GitHub Advisory Database · CC BY 4.0
- CVE-2020-7071 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences