Command injection in Gerapy
Priority MEDIUM 45CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
This affects the package Gerapy from 0 and before 0.9.3. The input being passed to Popen, via the project_configure endpoint, isn’t being sanitized.
Why it matters now
EPSS 0.01717 77th percentileScored 2026-11-07
Fix Fixed Gerapy: 0.9.3gerapy (PyPI): 0.9.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Gerapy | all versions; before 0.9.3 | 0.9.3 | Patch available | CNA |
| — | gerapy (PyPI) | before 0.9.3 | 0.9.3 | Patch available | GHSA-g57j-q48p-9vm2 |
- Gerapy Vendor— Affected all versions; before 0.9.3 Fixed in 0.9.3 Patch available CNA
- gerapy (PyPI) Vendor— Affected before 0.9.3 Fixed in 0.9.3 Patch available GHSA-g57j-q48p-9vm2
Remediation
- Fix · CNA Gerapy Fixed in 0.9.3
- Fix · GHSA-g57j-q48p-9vm2 gerapy (PyPI) Fixed in 0.9.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-7698
- 2026-10-03 Alias added: GHSA-g57j-q48p-9vm2
References
Advisory 2
More Gerapy vulnerabilities
- TI-2021-19663 Gerapy may contain remote code execution vulnerability CVSS 3.1CRITICAL 9.8
- TI-2021-12514 Arbitrary command execution in Gerapy CVSS 3.1HIGH 8.8
Sources
- CVE-2020-7698 · CVE Program
- CVE-2020-7698 · NVD
- FIRST EPSS
- GHSA-g57j-q48p-9vm2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences