Gerapy may contain remote code execution vulnerability
Priority HIGH 75CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8.
Why it matters now
EPSS 0.55608 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Gerapy (Gerapy): 0.9.8gerapy (PyPI): 0.9.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Gerapy | Gerapy | before 0.9.8 | 0.9.8 | Patch available | CNA |
| — | gerapy (PyPI) | before 0.9.8 | 0.9.8 | Patch available | GHSA-9w7f-m4j4-j3xw |
- Gerapy VendorGerapy Affected before 0.9.8 Fixed in 0.9.8 Patch available CNA
- gerapy (PyPI) Vendor— Affected before 0.9.8 Fixed in 0.9.8 Patch available GHSA-9w7f-m4j4-j3xw
Remediation
- Fix · CNA Gerapy (Gerapy) Fixed in 0.9.8
- Fix · GHSA-9w7f-m4j4-j3xw gerapy (PyPI) Fixed in 0.9.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-43857
- 2026-10-03 Alias added: GHSA-9w7f-m4j4-j3xw
References
Advisory 3
More Gerapy vulnerabilities
- TI-2021-12514 Arbitrary command execution in Gerapy CVSS 3.1HIGH 8.8
- TI-2020-06218 Command injection in Gerapy CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-43857 · CVE Program
- CVE-2021-43857 · NVD
- FIRST EPSS
- GHSA-9w7f-m4j4-j3xw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences