sql.rb in Geocoder before 1.6.1 allows Boolean-based SQL injection when…
Priority MEDIUM 45CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
sql.rb in Geocoder before 1.6.1 allows Boolean-based SQL injection when within_bounding_box is used in conjunction with untrusted sw_lat, sw_lng, ne_lat, or ne_lng data.
Why it matters now
EPSS 0.01484 74th percentileScored 2026-11-07
Fix Fixed geocoder (RubyGems): 1.6.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | geocoder (RubyGems) | before 1.6.1 | 1.6.1 | Patch available | GHSA-864j-6qpp-cmrr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- geocoder (RubyGems) Vendor— Affected before 1.6.1 Fixed in 1.6.1 Patch available GHSA-864j-6qpp-cmrr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rubygeocoder:geocoder:*:*:*:*:*:*:*:* | before 1.6.1 | Vulnerable | Rubygeocoder |
- cpe:2.3:a:rubygeocoder:geocoder:*:*:*:*:*:*:*:* Versions before 1.6.1 Vulnerable ·Rubygeocoder
Remediation
- Fix · GHSA-864j-6qpp-cmrr geocoder (RubyGems) Fixed in 1.6.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-7981
- 2026-10-03 Alias added: GHSA-864j-6qpp-cmrr
References
Advisory 2
Sources
- CVE-2020-7981 · CVE Program
- CVE-2020-7981 · NVD
- FIRST EPSS
- GHSA-864j-6qpp-cmrr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences