Cross-site scripting in reveal.js
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Insufficient validation in cross-origin communication (postMessage) in reveal.js version 3.9.1 and earlier allow attackers to perform cross-site scripting attacks.
Why it matters now
EPSS 0.01197 68th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed reveal.js (npm): 3.9.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | reveal.js | Fixed version: 3.9.2 | — | No fix listed | CNA |
| — | reveal.js (npm) | before 3.9.2 | 3.9.2 | Patch available | GHSA-6vwx-mwp8-fh44 |
- reveal.js Vendor— Affected Fixed version: 3.9.2 Fixed in — No fix listed CNA
- reveal.js (npm) Vendor— Affected before 3.9.2 Fixed in 3.9.2 Patch available GHSA-6vwx-mwp8-fh44
Remediation
- Fix · GHSA-6vwx-mwp8-fh44 reveal.js (npm) Fixed in 3.9.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8127
- 2026-10-03 Alias added: GHSA-6vwx-mwp8-fh44
References
More Revealjs Reveal.js vulnerabilities
- TI-2022-00685 Cross-site Scripting (XSS) - DOM in hakimel/reveal.js CVSS 3.1MEDIUM 6.1
Sources
- CVE-2020-8127 · CVE Program
- CVE-2020-8127 · NVD
- FIRST EPSS
- GHSA-6vwx-mwp8-fh44 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences