Read the docs
TI-2020-06553 Aliases CVE-2020-8135GHSA-mm7r-265w-jv6f

Server-side request forgery in uppy

Priority MEDIUM 45CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

The uppy npm package < 1.9.3 is vulnerable to a Server-Side Request Forgery (SSRF) vulnerability, which allows an attacker to scan local or external network or otherwise interact with internal systems.

Why it matters now

EPSS 0.01328 71st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed @uppy/companion (npm): 1.9.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—uppyFixed Version: 1.9.3—No fix listedCNA
—@uppy/companion (npm)before 1.9.31.9.3Patch availableGHSA-mm7r-265w-jv6f
  • uppy Vendor— Affected Fixed Version: 1.9.3 Fixed in — No fix listed CNA
  • @uppy/companion (npm) Vendor— Affected before 1.9.3 Fixed in 1.9.3 Patch available GHSA-mm7r-265w-jv6f

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:uppy:uppy:*:*:*:*:*:node.js:*:*before 1.9.3VulnerableUppy
  • cpe:2.3:a:uppy:uppy:*:*:*:*:*:node.js:*:* Versions before 1.9.3 Vulnerable ·Uppy

Remediation

  • Fix · GHSA-mm7r-265w-jv6f @uppy/companion (npm) Fixed in 1.9.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-8135
  2. 2026-10-03 Alias added: GHSA-mm7r-265w-jv6f

References

Sources