Path traversal in https://github.com/rack/rack
Priority MEDIUM 43CWE-548Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 2 fixed, 5 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-22 and the CVSS impact.
Summary
A directory traversal vulnerability exists in rack < 2.2.0 that allows an attacker perform directory traversal vulnerability in the Rack::Directory app that is bundled with Rack which could result in information disclosure.
Why it matters now
EPSS 0.03359 88th percentileScored 2026-11-07
Fix Partial rack (RubyGems): 2.1.3Red Hat: 1 advisoryRed Hat: 2 fixed, 5 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | https://github.com/rack/rack | Fixed in 2.1.3, >= 2.2.0 | — | No fix listed | CNA |
| — | rack (RubyGems) | before 2.1.3 | 2.1.3 | Patch available | GHSA-5f9h-9pjv-v6j7 |
- https://github.com/rack/rack Vendor— Affected Fixed in 2.1.3, >= 2.2.0 Fixed in — No fix listed CNA
- rack (RubyGems) Vendor— Affected before 2.1.3 Fixed in 2.1.3 Patch available GHSA-5f9h-9pjv-v6j7
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rack_project:rack:*:*:*:*:*:*:*:* | before 2.2.0 | Vulnerable | Rack Project |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
- cpe:2.3:a:rack_project:rack:*:*:*:*:*:*:*:* Versions before 2.2.0 Vulnerable ·Rack Project
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
Remediation
- Fix · GHSA-5f9h-9pjv-v6j7 rack (RubyGems) Fixed in 2.1.3 Advisory →
Red Hat 1 advisory
- RHSA-2020:4366 Released 2020-10-27 · Red Hat rating ImportantSatellite 6.8 release
- Red Hat Satellite 6.8 ansible-collection-redhat-satellite-1.3.0-1.el7sat, ansible-runner-1.4.6-1.el7ar, ansiblerole-foreman_scap_client-0.0.5-1.el7sat +47
- Red Hat Satellite Capsule 6.8 ansible-collection-redhat-satellite-1.3.0-1.el7sat, ansible-runner-1.4.6-1.el7ar, ansiblerole-foreman_scap_client-0.0.5-1.el7sat +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| CloudForms Management Engine 5 | Affected | No fix yet: Fix deferred |
| Red Hat OpenStack Platform 10 (Newton) Operational Tools | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 13 (Queens) Operational Tools | Affected | No fix yet: Fix deferred |
| Red Hat Satellite 6 | Affected | No fix yet |
| Red Hat Storage 3 | Affected | No fix yet: Fix deferred |
| Red Hat Satellite 6.8 | Fixed | RHSA-2020:4366 |
| Red Hat Satellite Capsule 6.8 | Fixed | RHSA-2020:4366 |
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8161
- 2026-10-03 Alias added: GHSA-5f9h-9pjv-v6j7
References
Advisory 5
Sources
- CVE-2020-8161 · CVE Program
- CVE-2020-8161 · NVD
- FIRST EPSS
- GHSA-5f9h-9pjv-v6j7 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-8161 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences