Read the docs
TI-2020-06602 Aliases CVE-2020-8184GHSA-j6w9-fv6q-3q52

Improper input validation in https://github.com/rack/rack

Priority LOW 38CWE-784Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Partial Red Hat: 2 fixed, 4 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

A reliance on cookies without validation/integrity check security vulnerability exists in rack < 2.2.3, rack < 2.1.4 that makes it is possible for an attacker to forge a secure or host-only cookie prefix.

Why it matters now

EPSS 0.03011 87th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial rack (RubyGems): 2.1.4, 2.2.3Red Hat: 1 advisoryRed Hat: 2 fixed, 4 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—https://github.com/rack/rackrack >= 2.2.3, rack >= 2.1.4—No fix listedCNA
—rack (RubyGems)before 2.1.42.1.4Patch availableGHSA-j6w9-fv6q-3q52
—rack (RubyGems)2.2.0 to before 2.2.32.2.3Patch availableGHSA-j6w9-fv6q-3q52
  • https://github.com/rack/rack Vendor— Affected rack >= 2.2.3, rack >= 2.1.4 Fixed in — No fix listed CNA
  • rack (RubyGems) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-j6w9-fv6q-3q52
  • rack (RubyGems) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-j6w9-fv6q-3q52

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:rack_project:rack:*:*:*:*:*:*:*:*before 2.1.4; 2.2.0 to before 2.2.3VulnerableRack Project
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*18.04VulnerableCanonical
  • cpe:2.3:a:rack_project:rack:*:*:*:*:*:*:*:* Versions before 2.1.4; 2.2.0 to before 2.2.3 Vulnerable ·Rack Project
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
  • cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical

Remediation

  • Fix · GHSA-j6w9-fv6q-3q52 rack (RubyGems) Fixed in 2.1.4 Advisory →
  • Fix · GHSA-j6w9-fv6q-3q52 rack (RubyGems) Fixed in 2.2.3 Advisory →

Red Hat 1 advisory

  • RHSA-2020:4366 Released 2020-10-27 · Red Hat rating Important
    Satellite 6.8 release
    • Red Hat Satellite 6.8 ansible-collection-redhat-satellite-1.3.0-1.el7sat, ansible-runner-1.4.6-1.el7ar, ansiblerole-foreman_scap_client-0.0.5-1.el7sat +47
    • Red Hat Satellite Capsule 6.8 ansible-collection-redhat-satellite-1.3.0-1.el7sat, ansible-runner-1.4.6-1.el7ar, ansiblerole-foreman_scap_client-0.0.5-1.el7sat +47

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
CloudForms Management Engine 5AffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 10 (Newton) Operational ToolsAffectedNo fix planned: Out of support scope
Red Hat OpenStack Platform 13 (Queens) Operational ToolsAffectedNo fix yet: Fix deferred
Red Hat Satellite 6AffectedNo fix yet
Red Hat Satellite 6.8Fixed RHSA-2020:4366
Red Hat Satellite Capsule 6.8Fixed RHSA-2020:4366
Not affected: 2 products
  • Red Hat Enterprise Linux 9
  • Red Hat Storage 3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-8184
  2. 2026-10-03 Alias added: GHSA-j6w9-fv6q-3q52

References

Sources