Buffer overflow in node-canvas
Priority MEDIUM 43CWE-120Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-120 and the CVSS impact.
Summary
A buffer overflow is present in canvas version <= 1.6.9, which could lead to a Denial of Service or execution of arbitrary code when it processes a user-provided image.
Why it matters now
EPSS 0.02323 83rd percentileScored 2026-11-07
Fix Fixed canvas (npm): 1.6.11
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | node-canvas | Not Fixed | — | No fix listed | CNA |
| — | canvas (npm) | before 1.6.11 | 1.6.11 | Patch available | GHSA-73rg-x683-m3qw |
- node-canvas Vendor— Affected Not Fixed Fixed in — No fix listed CNA
- canvas (npm) Vendor— Affected before 1.6.11 Fixed in 1.6.11 Patch available GHSA-73rg-x683-m3qw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:automattic:canvas:*:*:*:*:*:node.js:*:* | up to 1.6.9 | Vulnerable | Automattic |
- cpe:2.3:a:automattic:canvas:*:*:*:*:*:node.js:*:* Versions up to 1.6.9 Vulnerable ·Automattic
Remediation
- Fix · GHSA-73rg-x683-m3qw canvas (npm) Fixed in 1.6.11 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8215
- 2026-10-03 Alias added: GHSA-73rg-x683-m3qw
References
Sources
- CVE-2020-8215 · CVE Program
- CVE-2020-8215 · NVD
- FIRST EPSS
- GHSA-73rg-x683-m3qw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences