Read the docs
TI-2020-08694 Aliases CVE-2020-10804GHSA-h65r-8fp8-w7cx

In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was…

Priority LOW 39CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was found in retrieval of the current username (in libraries/classes/Server/Privileges.php and libraries/classes/UserPassword.php). A malicious user with access to the server could create a crafted username, and then trick the victim into performing specific actions with that user account (such as editing its privileges).

Why it matters now

EPSS 0.02355 83rd percentileScored 2026-11-07
Fix Fixed phpmyadmin/phpmyadmin (Packagist): 4.9.5, 5.0.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—phpmyadmin/phpmyadmin (Packagist)4.9.0 to before 4.9.54.9.5Patch availableGHSA-h65r-8fp8-w7cx
—phpmyadmin/phpmyadmin (Packagist)5.0.0 to before 5.0.25.0.2Patch availableGHSA-h65r-8fp8-w7cx
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 4.9.0 to before 4.9.5 Fixed in 4.9.5 Patch available GHSA-h65r-8fp8-w7cx
  • phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 5.0.0 to before 5.0.2 Fixed in 5.0.2 Patch available GHSA-h65r-8fp8-w7cx

CPE configurations NVD · 9

CPEVersionsRoleVendor
cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*4.0.0 to before 4.9.5; 5.0.0 to before 5.0.2VulnerablephpMyAdmin
cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:*30VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:*31VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*32VulnerableFedoraproject
cpe:2.3:a:opensuse:backports_sle:15.0:-:*:*:*:*:*:*15.0VulnerableopenSUSE
cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:*15.0 sp1VulnerableopenSUSE
cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:*15.1VulnerableopenSUSE
cpe:2.3:a:suse:package_hub:-:*:*:*:*:*:*:*not specified by NVDVulnerableSUSE
cpe:2.3:o:suse:linux_enterprise:12.0:*:*:*:*:*:*:*12.0Running onSUSE
  • cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.9.5; 5.0.0 to before 5.0.2 Vulnerable ·phpMyAdmin
  • cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* Versions 30 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject
  • cpe:2.3:a:opensuse:backports_sle:15.0:-:*:*:*:*:*:* Versions 15.0 Vulnerable ·openSUSE
  • cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* Versions 15.0 sp1 Vulnerable ·openSUSE
  • cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
  • cpe:2.3:a:suse:package_hub:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·SUSE
  • cpe:2.3:o:suse:linux_enterprise:12.0:*:*:*:*:*:*:* Versions 12.0 Running on ·SUSE

Remediation

  • Fix · GHSA-h65r-8fp8-w7cx phpmyadmin/phpmyadmin (Packagist) Fixed in 4.9.5 Advisory →
  • Fix · GHSA-h65r-8fp8-w7cx phpmyadmin/phpmyadmin (Packagist) Fixed in 5.0.2 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-10804
  2. 2026-10-03 Alias added: GHSA-h65r-8fp8-w7cx

References

Sources