Improper Restriction of Excessive Authentication Attempts in Sorcery
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-307.
Summary
In Sorcery before 0.15.0, there is a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout. This has been patched in 0.15.0.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Sorcery | Sorcery | before 0.15.0 | 0.15.0 | Patch available | CNA |
| — | sorcery (RubyGems) | before 0.15.0 | 0.15.0 | Patch available | GHSA-jc8m-cxhj-668x |
- Sorcery VendorSorcery Affected before 0.15.0 Fixed in 0.15.0 Patch available CNA
- sorcery (RubyGems) Vendor— Affected before 0.15.0 Fixed in 0.15.0 Patch available GHSA-jc8m-cxhj-668x
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sorcery_project:sorcery:*:*:*:*:*:ruby:*:* | before 0.15.0 | Vulnerable | Sorcery Project |
- cpe:2.3:a:sorcery_project:sorcery:*:*:*:*:*:ruby:*:* Versions before 0.15.0 Vulnerable ·Sorcery Project
Remediation
- Fix · CNA Sorcery (Sorcery) Fixed in 0.15.0
- Fix · GHSA-jc8m-cxhj-668x sorcery (RubyGems) Fixed in 0.15.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-11052
- 2026-10-03 Alias added: GHSA-jc8m-cxhj-668x
References
Patch 2
Advisory 3
Sources
- CVE-2020-11052 · CVE Program
- CVE-2020-11052 · NVD
- FIRST EPSS
- GHSA-jc8m-cxhj-668x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences