Weave Net clusters susceptible to MitM attacks via IPv6 rogue router advertisements
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
In Weave Net before version 2.6.3, an attacker able to run a process as root in a container is able to respond to DNS requests from the host and thereby insert themselves as a fake service. In a cluster with an IPv4 internal network, if IPv6 is not totally disabled on the host (via ipv6.disable=1 on the kernel cmdline), it will be either unconfigured or configured on some interfaces, but it's pretty likely that ipv6 forwarding is disabled, ie /proc/sys/net/ipv6/conf//forwarding == 0. Also by default, /proc/sys/net/ipv6/conf//accept_ra == 1. The combination of these 2 sysctls means that the host accepts router advertisements and configure the IPv6 stack using them. By sending rogue router advertisements, an attacker can reconfigure the host to redirect part or all of the IPv6 traffic of the host to the attacker controlled container. Even if there was no IPv6 traffic before, if the DNS returns A (IPv4) and AAAA (IPv6) records, many HTTP libraries will try to connect via IPv6 first then fallback to IPv4, giving an opportunity to the attacker to respond. If by chance you also have on the host a vulnerability like last year's RCE in apt (CVE-2019-3462), you can now escalate to the host. Weave Net version 2.6.3 disables the accept_ra option on the veth devices that it creates.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| weaveworks | Weave | before 2.6.3 | 2.6.3 | Patch available | CNA |
| — | github.com/weaveworks/weave (Go) | before 2.6.3 | 2.6.3 | Patch available | GHSA-59qg-grp7-5r73 |
- Weave Vendorweaveworks Affected before 2.6.3 Fixed in 2.6.3 Patch available CNA
- github.com/weaveworks/weave (Go) Vendor— Affected before 2.6.3 Fixed in 2.6.3 Patch available GHSA-59qg-grp7-5r73
Remediation
- Fix · CNA Weave (weaveworks) Fixed in 2.6.3
- Fix · GHSA-59qg-grp7-5r73 github.com/weaveworks/weave (Go) Fixed in 2.6.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-11091
- 2026-10-03 Alias added: GHSA-59qg-grp7-5r73
References
More weaveworks vulnerabilities
- TI-2022-16400 Improper object validation allows for arbitrary code execution in GitOps Tools Extension for VSCode CVSS 3.1CRITICAL 9.8
- TI-2022-16401 Improper KubeConfig handling allows arbitrary code execution CVSS 3.1CRITICAL 9.8
- TI-2022-13142 Weave GitOps leaked cluster credentials into logs on connection errors CVSS 3.1CRITICAL 9.0
- TI-2022-07567 GitOps Run allows for Kubernetes workload injection CVSS 3.1HIGH 8.9
- TI-2023-17072 Information Disclosure Vulnerability in Weave GitOps Terraform Controller CVSS 3.1HIGH 8.5
- TI-2020-16099 Weave Net Pods running in host PID namespace can be used to escalate other Kubernetes vulnerabilities CVSS 3.1HIGH 8.0
Sources
- CVE-2020-11091 · CVE Program
- CVE-2020-11091 · NVD
- FIRST EPSS
- GHSA-59qg-grp7-5r73 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences