Authorization bypass in express-jwt
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-285.
Summary
In express-jwt (NPM package) up and including version 5.3.3, the algorithms entry to be specified in the configuration is not being enforced. When algorithms is not specified in the configuration, with the combination of jwks-rsa, it may lead to authorization bypass. You are affected by this vulnerability if all of the following conditions apply: - You are using express-jwt - You do not have **algorithms** configured in your express-jwt configuration. - You are using libraries such as jwks-rsa as the **secret**. You can fix this by specifying **algorithms** in the express-jwt configuration. See linked GHSA for example. This is also fixed in version 6.0.0.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| auth0 | express-jwt | up to 5.3.3 | — | No fix listed | CNA |
| — | express-jwt (npm) | before 6.0.0 | 6.0.0 | Patch available | GHSA-6g6m-m6h5-w9gf |
- express-jwt Vendorauth0 Affected up to 5.3.3 Fixed in — No fix listed CNA
- express-jwt (npm) Vendor— Affected before 6.0.0 Fixed in 6.0.0 Patch available GHSA-6g6m-m6h5-w9gf
Remediation
- Fix · GHSA-6g6m-m6h5-w9gf express-jwt (npm) Fixed in 6.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15084
- 2026-10-03 Alias added: GHSA-6g6m-m6h5-w9gf
References
Sources
- CVE-2020-15084 · CVE Program
- CVE-2020-15084 · NVD
- FIRST EPSS
- GHSA-6g6m-m6h5-w9gf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences