Read the docs

auth0

Records58All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical11CVSS 9.0–10.0
CVSS high24CVSS 7.0–8.9

Exploited now

auth0 records in CISA KEV

No auth0 vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

58 records

Priority MEDIUM 53

In jsonwebtoken node module before 4.2.2 it is possible for an attacker to bypass verification when a token digitally signed with an asymmetric key (RS/ES family) of algorithms but instead the attacker send a token digit…

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.08367 Published 2018-05-29 Fixed in 4.2.2 CWE-20
TI-2020-11862 CVE-2020-15084 · GHSA-6g6m-m6h5-w9gf

Authorization bypass in express-jwt

Priority MEDIUM 42

In express-jwt (NPM package) up and including version 5.3.3, the algorithms entry to be specified in the configuration is not being enforced.

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.01221 Published 2020-06-30 Fixed in 6.0.0 CWE-285
Priority MEDIUM 41

The Auth0 AD/LDAP Connector is vulnerable to stored Cross-Site Scripting (XSS) issues due to improper HTML encoding of data in search results and updater log content displayed in the admin panel.

CVSS 3.1CRITICAL 9.0 Network Low privileges User interaction EPSS 0.00401 Published 2026-09-08 No fix listed CWE-79
TI-2020-12012 CVE-2020-15240 · GHSA-58r4-h6v8-jcvm

Regression in JWT Signature Validation

Priority MEDIUM 41

omniauth-auth0 (rubygems) versions >= 2.3.0 and < 2.4.1 improperly validate the JWT token signature when using the `jwt_validator.verify` method.

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.00803 Published 2020-10-21 Fixed in 2.4.1 CWE-287
TI-2021-18081 CVE-2021-41246 · GHSA-7rg2-qxmf-hhx9

Session fixation in express-openid-connect

Priority MEDIUM 40

Express OpenID Connect is express JS middleware implementing sign on for Express web apps using OpenID Connect.

CVSS 3.1HIGH 8.8 Network No auth User interaction EPSS 0.00924 Published 2021-12-09 Fixed in 2.5.2 CWE-384
Priority MEDIUM 40

ad-ldap-connector's admin panel before version 5.0.13 does not provide csrf protection, which when exploited may result in remote code execution or confidential data loss.

CVSS 3.1HIGH 8.8 Network No auth User interaction EPSS 0.00972 Published 2020-11-06 Fixed in 0.0.1 CWE-352
TI-2021-12309 CVE-2021-32641 · GHSA-jr3j-whm4-9wwm

Reflected XSS when using flashMessages

Priority LOW 38

auth0-lock is Auth0's signin solution.

CVSS 3.1HIGH 8.1 Network No auth No interaction EPSS 0.01539 Published 2021-06-04 Fixed in 11.30.1 CWE-79
Priority LOW 37

In auth0 (npm package) versions before 2.27.1, a DenyList of specific keys that should be sanitized from the request object contained in the error object is used.

CVSS 3.1HIGH 7.7 Network Low privileges No interaction EPSS 0.01539 Published 2020-07-29 Fixed in 2.27.1 CWE-209
Load more
Open these records in search →