TLS Validation Vulnerability in Envoy
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-346.
Summary
In Envoy before versions 1.12.6, 1.13.4, 1.14.4, and 1.15.0 when validating TLS certificates, Envoy would incorrectly allow a wildcard DNS Subject Alternative Name apply to multiple subdomains. For example, with a SAN of *.example.com, Envoy would incorrectly allow nested.subdomain.example.com, when it should only allow subdomain.example.com. This defect applies to both validating a client TLS certificate in mTLS, and validating a server TLS certificate for upstream connections. This vulnerability is only applicable to situations where an untrusted entity can obtain a signed wildcard TLS certificate for a domain of which you only intend to trust a subdomain of. For example, if you intend to trust api.mysubdomain.example.com, and an untrusted actor can obtain a signed TLS certificate for *.example.com or *.com. Configurations are vulnerable if they use verify_subject_alt_name in any Envoy version, or if they use match_subject_alt_names in version 1.14 or later. This issue has been fixed in Envoy versions 1.12.6, 1.13.4, 1.14.4, 1.15.0.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| envoyproxy | envoy | before 1.12.6; 1.13.0 to before 1.13.4; 1.14.0 to before 1.14.4 | 1.12.6, 1.13.4, 1.14.4 | Patch available | CNA |
- envoy Vendorenvoyproxy Affected before 1.12.6; 1.13.0 to before 1.13.4; 1.14.0 to before 1.14.4 Fixed in 1.12.6, 1.13.4, 1.14.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* | before 1.12.6; 1.13.0 to before 1.13.4; 1.14.0 to before 1.14.4 | Vulnerable | envoyproxy |
- cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* Versions before 1.12.6; 1.13.0 to before 1.13.4; 1.14.0 to before 1.14.4 Vulnerable ·envoyproxy
Remediation
- Fix · CNA envoy (envoyproxy) Fixed in 1.12.6, 1.13.4, 1.14.4
Red Hat 1 advisory
- RHSA-2020:3090 Released 2020-07-22 · Red Hat rating ModerateRed Hat OpenShift Service Mesh 1.1 servicemesh-proxy security update
- OpenShift Service Mesh 1.1 servicemesh-proxy-1.1.5-1.el8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Service Mesh 1.1 | Fixed | RHSA-2020:3090 |
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15104
References
More envoyproxy Envoy vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-20001 HTTP/2: CPU exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2024-18524 HTTP/2: memory exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2023-12215 Envoy client may fake the header `x-envoy-original-path` CVSS 3.1CRITICAL 9.1
- TI-2023-18002 Envoy vulnerable to OAuth2 credentials exploit with permanent validity CVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-15104 · CVE Program
- CVE-2020-15104 · NVD
- FIRST EPSS
- CVE-2020-15104 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences