Cross-Site Scripting in Wagtail
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In Wagtail before versions 2.7.4 and 2.9.3, when a form page type is made available to Wagtail editors through the `wagtail.contrib.forms` app, and the page template is built using Django's standard form rendering helpers such as form.as_p, any HTML tags used within a form field's help text will be rendered unescaped in the page. Allowing HTML within help text is an intentional design decision by Django; however, as a matter of policy Wagtail does not allow editors to insert arbitrary HTML by default, as this could potentially be used to carry out cross-site scripting attacks, including privilege escalation. This functionality should therefore not have been made available to editor-level users. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patched versions have been released as Wagtail 2.7.4 (for the LTS 2.7 branch) and Wagtail 2.9.3 (for the current 2.9 branch). In these versions, help text will be escaped to prevent the inclusion of HTML tags. Site owners who wish to re-enable the use of HTML within help text (and are willing to accept the risk of this being exploited by editors) may set WAGTAILFORMS_HELP_TEXT_ALLOW_HTML = True in their configuration settings. Site owners who are unable to upgrade to the new versions can secure their form page templates by rendering forms field-by-field as per Django's documentation, but omitting the |safe filter when outputting the help text.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| wagtail | wagtail | before 2.7.4; 2.8.0 to before 2.9.3 | 2.7.4, 2.9.3 | Patch available | CNA |
| — | wagtail (PyPI) | 2.8rc1 to before 2.9.3 | 2.9.3 | Patch available | GHSA-2473-9hgq-j7xw |
| — | wagtail (PyPI) | before 2.7.4 | 2.7.4 | Patch available | GHSA-2473-9hgq-j7xw |
- wagtail Vendorwagtail Affected before 2.7.4; 2.8.0 to before 2.9.3 Fixed in 2.7.4, 2.9.3 Patch available CNA
- wagtail (PyPI) Vendor— Affected 2.8rc1 to before 2.9.3 Fixed in 2.9.3 Patch available GHSA-2473-9hgq-j7xw
- wagtail (PyPI) Vendor— Affected before 2.7.4 Fixed in 2.7.4 Patch available GHSA-2473-9hgq-j7xw
Remediation
- Fix · CNA wagtail (wagtail) Fixed in 2.7.4, 2.9.3
- Fix · GHSA-2473-9hgq-j7xw wagtail (PyPI) Fixed in 2.9.3 Advisory →
- Fix · GHSA-2473-9hgq-j7xw wagtail (PyPI) Fixed in 2.7.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15118
- 2026-10-03 Alias added: GHSA-2473-9hgq-j7xw
References
Advisory 5
- https://github.com/wagtail/wagtail/security/advisories/GHSA-2473-9hgq-j7xw
- https://docs.djangoproject.com/en/3.0/ref/models/fields/#django.db.models.Field.help_text
- https://docs.wagtail.io/en/stable/reference/contrib/forms/index.html#usage
- https://github.com/wagtail/wagtail/blob/master/docs/releases/2.9.3.rst
- https://nvd.nist.gov/vuln/detail/CVE-2020-15118
More Wagtail vulnerabilities
- TI-2026-39163 Wagtail: Reflected XSS in dynamic image URL generator view CVSS 3.1HIGH 7.3
- TI-2020-08875 Possible XSS attack in Wagtail CVSS 3.1MEDIUM 6.8
- TI-2023-13342 Wagtail vulnerable to stored Cross-site Scripting attack via ModelAdmin views CVSS 3.1MEDIUM 6.4
- TI-2026-32180 Wagtail: Improper restriction handling on Documents and Images API CVSS 3.1MEDIUM 5.3
- TI-2026-22558 Wagtail: Improper escaping of HTML (Cross-site Scripting) in simple_translation admin interface CVSS 3.1MEDIUM 6.1
- TI-2026-22557 Wagtail: Improper escaping of HTML (Cross-site Scripting) on TableBlock class attributes CVSS 3.1MEDIUM 6.1
Sources
- CVE-2020-15118 · CVE Program
- CVE-2020-15118 · NVD
- FIRST EPSS
- GHSA-2473-9hgq-j7xw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences