Read the docs
TI-2020-12012 Aliases CVE-2020-15240GHSA-58r4-h6v8-jcvm

Regression in JWT Signature Validation

Priority MEDIUM 41CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.

Summary

omniauth-auth0 (rubygems) versions >= 2.3.0 and < 2.4.1 improperly validate the JWT token signature when using the `jwt_validator.verify` method. Improper validation of the JWT token signature can allow an attacker to bypass authentication and authorization. You are affected by this vulnerability if all of the following conditions apply: 1. You are using `omniauth-auth0`. 2. You are using `JWTValidator.verify` method directly OR you are not authenticating using the SDK’s default Authorization Code Flow. The issue is patched in version 2.4.1.

Why it matters now

EPSS 0.00803 56th percentileScored 2026-11-07
Fix Fixed omniauth-auth0 (auth0): 2.4.1omniauth-auth0 (RubyGems): 2.4.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
auth0omniauth-auth02.3.0 to before 2.4.12.4.1Patch availableCNA
—omniauth-auth0 (RubyGems)2.3.0 to before 2.4.12.4.1Patch availableGHSA-58r4-h6v8-jcvm
  • omniauth-auth0 Vendorauth0 Affected 2.3.0 to before 2.4.1 Fixed in 2.4.1 Patch available CNA
  • omniauth-auth0 (RubyGems) Vendor— Affected 2.3.0 to before 2.4.1 Fixed in 2.4.1 Patch available GHSA-58r4-h6v8-jcvm

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:auth0:omniauth-auth0:*:*:*:*:*:ruby:*:*2.3.0 to before 2.4.1Vulnerableauth0
  • cpe:2.3:a:auth0:omniauth-auth0:*:*:*:*:*:ruby:*:* Versions 2.3.0 to before 2.4.1 Vulnerable ·auth0

Remediation

  • Fix · CNA omniauth-auth0 (auth0) Fixed in 2.4.1
  • Fix · GHSA-58r4-h6v8-jcvm omniauth-auth0 (RubyGems) Fixed in 2.4.1 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-15240
  2. 2026-10-03 Alias added: GHSA-58r4-h6v8-jcvm

References

Sources