RCE in Magento
Priority LOW 37CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
In Magento (rubygems openmage/magento-lts package) before versions 19.4.8 and 20.0.4, an admin user can generate soap credentials that can be used to trigger RCE via PHP Object Injection through product attributes and a product. The issue is patched in versions 19.4.8 and 20.0.4.
Why it matters now
EPSS 0.01264 69th percentileScored 2026-11-07
Fix Fixed magento-lts (OpenMage): 19.4.8, 20.0.4openmage/magento-lts (Packagist): 19.4.8, 20.0.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenMage | magento-lts | before 19.4.8; 20.0.0 to before 20.0.4 | 19.4.8, 20.0.4 | Patch available | CNA |
| — | openmage/magento-lts (Packagist) | before 19.4.8 | 19.4.8 | Patch available | GHSA-jrgf-vfw2-hj26 |
| — | openmage/magento-lts (Packagist) | 20.0.0 to before 20.0.4 | 20.0.4 | Patch available | GHSA-jrgf-vfw2-hj26 |
- magento-lts VendorOpenMage Affected before 19.4.8; 20.0.0 to before 20.0.4 Fixed in 19.4.8, 20.0.4 Patch available CNA
- openmage/magento-lts (Packagist) Vendor— Affected before 19.4.8 Fixed in 19.4.8 Patch available GHSA-jrgf-vfw2-hj26
- openmage/magento-lts (Packagist) Vendor— Affected 20.0.0 to before 20.0.4 Fixed in 20.0.4 Patch available GHSA-jrgf-vfw2-hj26
Remediation
- Fix · CNA magento-lts (OpenMage) Fixed in 19.4.8, 20.0.4
- Fix · GHSA-jrgf-vfw2-hj26 openmage/magento-lts (Packagist) Fixed in 19.4.8 Advisory →
- Fix · GHSA-jrgf-vfw2-hj26 openmage/magento-lts (Packagist) Fixed in 20.0.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15244
- 2026-10-03 Alias added: GHSA-jrgf-vfw2-hj26
References
More OpenMage Magento vulnerabilities
- TI-2026-20633 OpenMage LTS's Phar Deserialization leads to Remote Code Execution CVSS 3.1HIGH 8.1
- TI-2026-29239 OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution CVSS 4.0HIGH 8.7
- TI-2023-22272 Magento LTS's guest order "protect code" can be brute-forced too easily CVSS 3.1HIGH 7.5
- TI-2026-28925 Missing authorization in OpenMage magento-lts CVSS 4.0MEDIUM 5.3
- TI-2026-20634 OpenMage LTS has Path Traversal Filter Bypass in Dataflow Module CVSS 3.1MEDIUM 4.9
- TI-2025-39617 OpenMage is vulnerable to XSS in Admin Notifications CVSS 4.0MEDIUM 4.6
Sources
- CVE-2020-15244 · CVE Program
- CVE-2020-15244 · NVD
- FIRST EPSS
- GHSA-jrgf-vfw2-hj26 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences