containerd-shim API Exposed to Host Network Containers
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 1 fixed, 2 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
containerd is an industry-standard container runtime and is available as a daemon for Linux and Windows. In containerd before versions 1.3.9 and 1.4.3, the containerd-shim API is improperly exposed to host network containers. Access controls for the shim’s API socket verified that the connecting process had an effective UID of 0, but did not otherwise restrict access to the abstract Unix domain socket. This would allow malicious containers running in the same network namespace as the shim, with an effective UID of 0 but otherwise reduced privileges, to cause new processes to be run with elevated privileges. This vulnerability has been fixed in containerd 1.3.9 and 1.4.3. Users should update to these versions as soon as they are released. It should be noted that containers started with an old version of containerd-shim should be stopped and restarted, as running containers will continue to be vulnerable even after an upgrade. If you are not providing the ability for untrusted users to start containers in the same network namespace as the shim (typically the "host" network namespace, for example with docker run --net=host or hostNetwork: true in a Kubernetes pod) and run with an effective UID of 0, you are not vulnerable to this issue. If you are running containers with a vulnerable configuration, you can deny access to all abstract sockets with AppArmor by adding a line similar to deny unix addr=@**, to your policy. It is best practice to run containers with a reduced set of privileges, with a non-zero UID, and with isolated namespaces. The containerd maintainers strongly advise against sharing namespaces with the host. Reducing the set of isolation mechanisms used for a container necessarily increases that container's privilege, regardless of what container runtime is used for running that container.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| backstage | containerd | before 1.3.9; 1.4.0 to before 1.4.3 | 1.3.9, 1.4.3 | Patch available | CNA |
| — | github.com/containerd/containerd (Go) | before 1.3.9 | 1.3.9 | Patch available | GHSA-36xw-fx78-c5r4 |
| — | github.com/containerd/containerd (Go) | 1.4.0 to before 1.4.3 | 1.4.3 | Patch available | GHSA-36xw-fx78-c5r4 |
- containerd Vendorbackstage Affected before 1.3.9; 1.4.0 to before 1.4.3 Fixed in 1.3.9, 1.4.3 Patch available CNA
- github.com/containerd/containerd (Go) Vendor— Affected before 1.3.9 Fixed in 1.3.9 Patch available GHSA-36xw-fx78-c5r4
- github.com/containerd/containerd (Go) Vendor— Affected 1.4.0 to before 1.4.3 Fixed in 1.4.3 Patch available GHSA-36xw-fx78-c5r4
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:* | before 1.3.9; 1.4.0 to before 1.4.3 | Vulnerable | backstage |
| cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* | 33 | Vulnerable | Fedoraproject |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:* Versions before 1.3.9; 1.4.0 to before 1.4.3 Vulnerable ·backstage
- cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA containerd (containerd) Fixed in 1.3.9, 1.4.3
- Fix · GHSA-36xw-fx78-c5r4 github.com/containerd/containerd (Go) Fixed in 1.3.9 Advisory →
- Fix · GHSA-36xw-fx78-c5r4 github.com/containerd/containerd (Go) Fixed in 1.4.3 Advisory →
Red Hat 1 advisory
- RHSA-2022:2183 Released 2022-05-11 · Red Hat rating ModerateRelease of containers for OSP 16.2.z director operator tech preview
- Red Hat OpenStack Platform 16.2 rhosp-rhel8-tech-preview/osp-director-operator
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat 3scale API Management Platform 2 | Affected | No fix yet |
| Red Hat OpenStack Platform 16.2 | Affected | No fix yet |
| Red Hat OpenStack Platform 16.2 | Fixed | RHSA-2022:2183 |
Not affected: 3 products
- Red Hat Advanced Cluster Management for Kubernetes 2
- Red Hat OpenShift Container Platform 4
- Red Hat OpenStack Platform 16.2
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15257
- 2026-10-03 Alias added: GHSA-36xw-fx78-c5r4
References
Advisory 6
More backstage Containerd vulnerabilities
- TI-2021-19622 Improper Preservation of Permissions in containerd CVSS 3.1CRITICAL 9.1
- TI-2023-10635 containerd supplementary groups are not set up properly CVSS 3.1HIGH 7.8
- TI-2022-07700 Insecure handling of image volumes in containerd CRI plugin CVSS 3.1HIGH 7.5
- TI-2026-38567 Improper input validation in backstage containerd CVSS 4.0CRITICAL 9.4
- TI-2026-38569 containerd CRI checkpoint restore CDI annotation smuggling CVSS 4.0HIGH 8.4
- TI-2025-29820 Containerd vulnerable to host filesystem access during image unpack CVSS 4.0HIGH 7.6
Sources
- CVE-2020-15257 · CVE Program
- CVE-2020-15257 · NVD
- FIRST EPSS
- GHSA-36xw-fx78-c5r4 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-15257 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences