Shell Command Execution in lookatme
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
In lookatme (python/pypi package) versions prior to 2.3.0, the package automatically loaded the built-in "terminal" and "file_loader" extensions. Users that use lookatme to render untrusted markdown may have malicious shell commands automatically run on their system. This is fixed in version 2.3.0. As a workaround, the `lookatme/contrib/terminal.py` and `lookatme/contrib/file_loader.py` files may be manually deleted. Additionally, it is always recommended to be aware of what is being rendered with lookatme.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| d0c-s4vage | lookatme | before 2.3.0 | 2.3.0 | Patch available | CNA |
| — | lookatme (PyPI) | before 2.3.0 | 2.3.0 | Patch available | GHSA-c84h-w6cr-5v8q |
- lookatme Vendord0c-s4vage Affected before 2.3.0 Fixed in 2.3.0 Patch available CNA
- lookatme (PyPI) Vendor— Affected before 2.3.0 Fixed in 2.3.0 Patch available GHSA-c84h-w6cr-5v8q
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:lookatme_project:lookatme:*:*:*:*:*:*:*:* | before 2.3.0 | Vulnerable | Lookatme Project |
- cpe:2.3:a:lookatme_project:lookatme:*:*:*:*:*:*:*:* Versions before 2.3.0 Vulnerable ·Lookatme Project
Remediation
- Fix · CNA lookatme (d0c-s4vage) Fixed in 2.3.0
- Fix · GHSA-c84h-w6cr-5v8q lookatme (PyPI) Fixed in 2.3.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15271
- 2026-10-03 Alias added: GHSA-c84h-w6cr-5v8q
References
Advisory 4
Sources
- CVE-2020-15271 · CVE Program
- CVE-2020-15271 · NVD
- FIRST EPSS
- GHSA-c84h-w6cr-5v8q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences