Potential double-free in pulseaudio
Priority LOW 27CWE-415Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Potential double free in Bluez 5 module of PulseAudio could allow a local attacker to leak memory or crash the program. The modargs variable may be freed twice in the fail condition in src/modules/bluetooth/module-bluez5-device.c and src/modules/bluetooth/module-bluez5-device.c. Fixed in 1:8.0-0ubuntu3.14.
Why it matters now
EPSS 0.00298 22nd percentileScored 2026-11-07
Fix Fixed PulseAudio (Canonical): 1:8.0-0ubuntu3.14
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Canonical | PulseAudio | 1:8.0 to before 1:8.0-0ubuntu3.14 | 1:8.0-0ubuntu3.14 | Patch available | CNA |
- PulseAudio VendorCanonical Affected 1:8.0 to before 1:8.0-0ubuntu3.14 Fixed in 1:8.0-0ubuntu3.14 Patch available CNA
CPE configurations NVD · 17
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu1:*:*:*:*:*:*:* | 1 8.0-0ubuntu1 | Vulnerable | Pulseaudio Project |
| cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu2:*:*:*:*:*:*:* | 1 8.0-0ubuntu2 | Vulnerable | Pulseaudio Project |
| cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3:*:*:*:*:*:*:* | 1 8.0-0ubuntu3 | Vulnerable | Pulseaudio Project |
| cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.1:*:*:*:*:*:*:* | 1 8.0-0ubuntu3.1 | Vulnerable | Pulseaudio Project |
| cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.2:*:*:*:*:*:*:* | 1 8.0-0ubuntu3.2 | Vulnerable | Pulseaudio Project |
| cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.3:*:*:*:*:*:*:* | 1 8.0-0ubuntu3.3 | Vulnerable | Pulseaudio Project |
| cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.4:*:*:*:*:*:*:* | 1 8.0-0ubuntu3.4 | Vulnerable | Pulseaudio Project |
| cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.5:*:*:*:*:*:*:* | 1 8.0-0ubuntu3.5 | Vulnerable | Pulseaudio Project |
| cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.6:*:*:*:*:*:*:* | 1 8.0-0ubuntu3.6 | Vulnerable | Pulseaudio Project |
| cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.7:*:*:*:*:*:*:* | 1 8.0-0ubuntu3.7 | Vulnerable | Pulseaudio Project |
- cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu1:*:*:*:*:*:*:* Versions 1 8.0-0ubuntu1 Vulnerable ·Pulseaudio Project
- cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu2:*:*:*:*:*:*:* Versions 1 8.0-0ubuntu2 Vulnerable ·Pulseaudio Project
- cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3:*:*:*:*:*:*:* Versions 1 8.0-0ubuntu3 Vulnerable ·Pulseaudio Project
- cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.1:*:*:*:*:*:*:* Versions 1 8.0-0ubuntu3.1 Vulnerable ·Pulseaudio Project
- cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.2:*:*:*:*:*:*:* Versions 1 8.0-0ubuntu3.2 Vulnerable ·Pulseaudio Project
- cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.3:*:*:*:*:*:*:* Versions 1 8.0-0ubuntu3.3 Vulnerable ·Pulseaudio Project
- cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.4:*:*:*:*:*:*:* Versions 1 8.0-0ubuntu3.4 Vulnerable ·Pulseaudio Project
- cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.5:*:*:*:*:*:*:* Versions 1 8.0-0ubuntu3.5 Vulnerable ·Pulseaudio Project
- cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.6:*:*:*:*:*:*:* Versions 1 8.0-0ubuntu3.6 Vulnerable ·Pulseaudio Project
- cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.7:*:*:*:*:*:*:* Versions 1 8.0-0ubuntu3.7 Vulnerable ·Pulseaudio Project
Show 7 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.8:*:*:*:*:*:*:* | 1 8.0-0ubuntu3.8 | Vulnerable | Pulseaudio Project |
| cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.9:*:*:*:*:*:*:* | 1 8.0-0ubuntu3.9 | Vulnerable | Pulseaudio Project |
| cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.10:*:*:*:*:*:*:* | 1 8.0-0ubuntu3.10 | Vulnerable | Pulseaudio Project |
| cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.11:*:*:*:*:*:*:* | 1 8.0-0ubuntu3.11 | Vulnerable | Pulseaudio Project |
| cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.12:*:*:*:*:*:*:* | 1 8.0-0ubuntu3.12 | Vulnerable | Pulseaudio Project |
| cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu4:*:*:*:*:*:*:* | 1 8.0-0ubuntu4 | Vulnerable | Pulseaudio Project |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Running on | Canonical |
- cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.8:*:*:*:*:*:*:* Versions 1 8.0-0ubuntu3.8 Vulnerable ·Pulseaudio Project
- cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.9:*:*:*:*:*:*:* Versions 1 8.0-0ubuntu3.9 Vulnerable ·Pulseaudio Project
- cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.10:*:*:*:*:*:*:* Versions 1 8.0-0ubuntu3.10 Vulnerable ·Pulseaudio Project
- cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.11:*:*:*:*:*:*:* Versions 1 8.0-0ubuntu3.11 Vulnerable ·Pulseaudio Project
- cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu3.12:*:*:*:*:*:*:* Versions 1 8.0-0ubuntu3.12 Vulnerable ·Pulseaudio Project
- cpe:2.3:a:pulseaudio_project:pulseaudio:1\:8.0-0ubuntu4:*:*:*:*:*:*:* Versions 1 8.0-0ubuntu4 Vulnerable ·Pulseaudio Project
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Running on ·Canonical
Remediation
- Fix · CNA PulseAudio (Canonical) Fixed in 1:8.0-0ubuntu3.14
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15710
- 2026-10-03 Alias added: GHSA-87cm-47xv-j472
References
More Canonical vulnerabilities
- TI-2020-09349 An issue was discovered in SaltStack Salt before 2019.2.4 and 3000 before 3000.2. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-05854 smtp_mailaddr in smtp_session.c in OpenSMTPD 6.6, as used in OpenBSD 6.6 and other… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-01431 Netlogon Elevation of Privilege Vulnerability KEVCVSS 3.1CRITICAL 10.0
- TI-2019-12627 Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than… KEVCVSS 3.1CRITICAL 9.8
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-07471 OS command injection in exim KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-15710 · CVE Program
- CVE-2020-15710 · NVD
- FIRST EPSS
- GHSA-87cm-47xv-j472 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences