Read the docs
TI-2020-13281 Aliases CVE-2020-17533GHSA-grc3-8q8m-4j7c

Apache Accumulo Improper Handling of Insufficient Permissions

Priority MEDIUM 42CWE-252Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Apache Accumulo versions 1.5.0 through 1.10.0 and version 2.0.0 do not properly check the return value of some policy enforcement functions before permitting an authenticated user to perform certain administrative operations. Specifically, the return values of the 'canFlush' and 'canPerformSystemActions' security functions are not checked in some instances, therefore allowing an authenticated user with insufficient permissions to perform the following actions: flushing a table, shutting down Accumulo or an individual tablet server, and setting or removing system-wide Accumulo configuration properties.

Why it matters now

EPSS 0.03699 89th percentileScored 2026-11-07
Fix Fixed org.apache.accumulo:accumulo-master (Maven): 1.10.1, 2.0.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache AccumuloApache Accumulo 2.0.0; 1.5.0 and later—No fix listedCNA
—org.apache.accumulo:accumulo-master (Maven)1.5.0 to before 1.10.11.10.1Patch availableGHSA-grc3-8q8m-4j7c
—org.apache.accumulo:accumulo-master (Maven)2.0.0 to before 2.0.12.0.1Patch availableGHSA-grc3-8q8m-4j7c
  • Apache Accumulo VendorApache Affected Apache Accumulo 2.0.0; 1.5.0 and later Fixed in — No fix listed CNA
  • org.apache.accumulo:accumulo-master (Maven) Vendor— Affected 1.5.0 to before 1.10.1 Fixed in 1.10.1 Patch available GHSA-grc3-8q8m-4j7c
  • org.apache.accumulo:accumulo-master (Maven) Vendor— Affected 2.0.0 to before 2.0.1 Fixed in 2.0.1 Patch available GHSA-grc3-8q8m-4j7c

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:apache:accumulo:*:*:*:*:*:*:*:*1.5.0 – 1.10.0VulnerableApache
cpe:2.3:a:apache:accumulo:2.0.0:-:*:*:*:*:*:*2.0.0VulnerableApache
  • cpe:2.3:a:apache:accumulo:*:*:*:*:*:*:*:* Versions 1.5.0 – 1.10.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:accumulo:2.0.0:-:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Apache

Remediation

  • Fix · GHSA-grc3-8q8m-4j7c org.apache.accumulo:accumulo-master (Maven) Fixed in 1.10.1 Advisory →
  • Fix · GHSA-grc3-8q8m-4j7c org.apache.accumulo:accumulo-master (Maven) Fixed in 2.0.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-17533
  2. 2026-10-03 Alias added: GHSA-grc3-8q8m-4j7c

References

  • TI-2023-17172 Apache Accumulo: Accumulo 2.1.0 may incorrectly validate cached credentials CVSS 3.1CRITICAL 9.8
  • TI-2026-44861 Apache Accumulo: A user can trigger a graceful shutdown of services without the relevant system permissions CVSS 4.0MEDIUM 5.7

Sources