Apache Accumulo: Accumulo 2.1.0 may incorrectly validate cached credentials
Priority MEDIUM 52CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Improper Authentication vulnerability in Apache Software Foundation Apache Accumulo. This issue affects Apache Accumulo: 2.1.0. Accumulo 2.1.0 contains a defect in the user authentication process that may succeed when invalid credentials are provided. Users are advised to upgrade to 2.1.1.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01432 73rd percentileScored 2026-11-07
Fix Fixed Apache Accumulo (Apache Software Foundation): 2.1.1org.apache.accumulo:accumulo-shell (Maven): 2.1.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Accumulo | 2.1.0 to before 2.1.1 | 2.1.1 | Patch available | CNA |
| — | org.apache.accumulo:accumulo-shell (Maven) | 2.1.0 to before 2.1.1 | 2.1.1 | Patch available | GHSA-hp5w-w29m-vg63 |
- Apache Accumulo VendorApache Affected 2.1.0 to before 2.1.1 Fixed in 2.1.1 Patch available CNA
- org.apache.accumulo:accumulo-shell (Maven) Vendor— Affected 2.1.0 to before 2.1.1 Fixed in 2.1.1 Patch available GHSA-hp5w-w29m-vg63
Remediation
- Fix · CNA Apache Accumulo (Apache Software Foundation) Fixed in 2.1.1
- Fix · GHSA-hp5w-w29m-vg63 org.apache.accumulo:accumulo-shell (Maven) Fixed in 2.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-34340
- 2026-10-03 Alias added: GHSA-hp5w-w29m-vg63
References
Advisory 2
Other 7
- https://accumulo.apache.org/release/accumulo-2.1.1/
- https://github.com/apache/accumulo/issues/3427
- https://github.com/apache/accumulo/issues/3433
- https://github.com/apache/accumulo/pull/3440
- https://github.com/apache/accumulo/commit/0f2389735fd32e0bbc93ecde5d8c814b275b21b5
- https://accumulo.apache.org/release/accumulo-2.1.1
- https://github.com/apache/accumulo
More Apache Accumulo vulnerabilities
- TI-2020-13281 Apache Accumulo Improper Handling of Insufficient Permissions CVSS 3.1HIGH 8.1
- TI-2026-44861 Apache Accumulo: A user can trigger a graceful shutdown of services without the relevant system permissions CVSS 4.0MEDIUM 5.7
Sources
- CVE-2023-34340 · CVE Program
- CVE-2023-34340 · NVD
- FIRST EPSS
- GHSA-hp5w-w29m-vg63 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences