Local Privilege Escalation in cloudflared
Priority LOW 34CWE-427Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-427.
Summary
`cloudflared` versions prior to 2020.8.1 contain a local privilege escalation vulnerability on Windows systems. When run on a Windows system, `cloudflared` searches for configuration files which could be abused by a malicious entity to execute commands as a privileged user. Version 2020.8.1 fixes this issue.
Why it matters now
EPSS 0.00348 28th percentileScored 2026-11-07
Fix Fixed cloudflared (Cloudflare): 2020.8.1github.com/cloudflare/cloudflared (Go): 0.0.0-20200820025921-9323844ea773
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cloudflare | cloudflared | before 2020.8.1 | 2020.8.1 | Patch available | CNA |
| — | github.com/cloudflare/cloudflared (Go) | before 0.0.0-20200820025921-9323844ea773 | 0.0.0-20200820025921-9323844ea773 | Patch available | GHSA-hgwp-4vp4-qmm2 |
- cloudflared VendorCloudflare Affected before 2020.8.1 Fixed in 2020.8.1 Patch available CNA
- github.com/cloudflare/cloudflared (Go) Vendor— Affected before 0.0.0-20200820025921-9323844ea773 Fixed in 0.0.0-20200820025921-9323844ea773 Patch available GHSA-hgwp-4vp4-qmm2
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cloudflare:cloudflared:*:*:*:*:*:*:*:* | before 2020.8.1 | Vulnerable | Cloudflare |
- cpe:2.3:a:cloudflare:cloudflared:*:*:*:*:*:*:*:* Versions before 2020.8.1 Vulnerable ·Cloudflare
Remediation
- Fix · CNA cloudflared (Cloudflare) Fixed in 2020.8.1
- Fix · GHSA-hgwp-4vp4-qmm2 github.com/cloudflare/cloudflared (Go) Fixed in 0.0.0-20200820025921-9323844ea773 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-24356
- 2026-10-03 Alias added: GHSA-hgwp-4vp4-qmm2
References
More Cloudflared vulnerabilities
- TI-2023-01241 Local Privilege Escalation Vulnerability in cloudflared's Installer CVSS 3.1HIGH 7.8
Sources
- CVE-2020-24356 · CVE Program
- CVE-2020-24356 · NVD
- FIRST EPSS
- GHSA-hgwp-4vp4-qmm2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences