SilverStripe through 4.6.0-rc1 has an XXE Vulnerability in CSSContentParser.
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
SilverStripe through 4.6.0-rc1 has an XXE Vulnerability in CSSContentParser. A developer utility meant for parsing HTML within unit tests can be vulnerable to XML External Entity (XXE) attacks. When this developer utility is misused for purposes involving external or user submitted data in custom project code, it can lead to vulnerabilities such as XSS on HTML output rendered through this custom code. This is now mitigated by disabling external entities during parsing. (The correct CVE ID year is 2020 [CVE-2020-25817, not CVE-2021-25817]).
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | silverstripe/framework (Packagist) | 4.0.0 to before 4.7.4 | 4.7.4 | Patch available | GHSA-3vjc-5x79-m9r8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- silverstripe/framework (Packagist) Vendor— Affected 4.0.0 to before 4.7.4 Fixed in 4.7.4 Patch available GHSA-3vjc-5x79-m9r8
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:silverstripe:silverstripe:*:*:*:*:*:*:*:* | before 4.6.0 | Vulnerable | silverstripe |
| cpe:2.3:a:silverstripe:silverstripe:4.6.0:rc1:*:*:*:*:*:* | 4.6.0 rc1 | Vulnerable | silverstripe |
- cpe:2.3:a:silverstripe:silverstripe:*:*:*:*:*:*:*:* Versions before 4.6.0 Vulnerable ·silverstripe
- cpe:2.3:a:silverstripe:silverstripe:4.6.0:rc1:*:*:*:*:*:* Versions 4.6.0 rc1 Vulnerable ·silverstripe
Remediation
- Fix · GHSA-3vjc-5x79-m9r8 silverstripe/framework (Packagist) Fixed in 4.7.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-25817
- 2026-10-03 Alias added: GHSA-3vjc-5x79-m9r8
References
Advisory 4
More Silverstripe vulnerabilities
- TI-2007-02239 Unspecified vulnerability in the search functionality in SilverStripe 2.0.0 has unknown impact and attack vectors. CVSS 2.0HIGH 10.0
- TI-2019-09110 In SilverStripe through 4.3.3, a missing warning about leaving install.php in a public… CVSS 3.1CRITICAL 9.8
- TI-2019-04049 All versions of SilverStripe 3 prior to 3.6.7 and 3.7.3, and all versions of SilverStripe… CVSS 3.0CRITICAL 9.8
- TI-2019-09281 In SilverStripe through 4.3.3, the previous fix for SS-2018-007 does not completely… CVSS 3.1HIGH 8.8
- TI-2011-04272 code/sitefeatures/PageCommentInterface.php in SilverStripe 2.4.x before 2.4.6 might allow… CVSS 2.0MEDIUM 6.8
- TI-2020-07421 In SilverStripe through 4.5, files uploaded via Forms to folders migrated from… CVSS 3.1HIGH 7.5
Sources
- CVE-2020-25817 · CVE Program
- CVE-2020-25817 · NVD
- FIRST EPSS
- GHSA-3vjc-5x79-m9r8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences