Improper privilege management in Dell PowerScale OneFS
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
Dell EMC PowerScale OneFS versions 8.1.0 - 9.1.0 contain a privilege escalation vulnerability. A user with ISI_PRIV_JOB_ENGINE may use the PermissionRepair job to grant themselves the highest level of RBAC privileges thus being able to read arbitrary data, tamper with system software or deny service to users.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | PowerScale OneFS | before 8.1.2, 8.2.2, 9.1.0+ | 8.1.2, 8.2.2, 9.1.0+ | Patch available | CNA |
- PowerScale OneFS VendorDell Affected before 8.1.2, 8.2.2, 9.1.0+ Fixed in 8.1.2, 8.2.2, 9.1.0+ Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:emc_powerscale_onefs:8.1.0:*:*:*:*:*:*:* | 8.1.0 | Vulnerable | Dell |
| cpe:2.3:o:dell:emc_powerscale_onefs:8.1.1:*:*:*:*:*:*:* | 8.1.1 | Vulnerable | Dell |
| cpe:2.3:o:dell:emc_powerscale_onefs:8.1.2:*:*:*:*:*:*:* | 8.1.2 | Vulnerable | Dell |
| cpe:2.3:o:dell:emc_powerscale_onefs:8.2.0:*:*:*:*:*:*:* | 8.2.0 | Vulnerable | Dell |
| cpe:2.3:o:dell:emc_powerscale_onefs:8.2.1:*:*:*:*:*:*:* | 8.2.1 | Vulnerable | Dell |
| cpe:2.3:o:dell:emc_powerscale_onefs:8.2.2:*:*:*:*:*:*:* | 8.2.2 | Vulnerable | Dell |
| cpe:2.3:o:dell:emc_powerscale_onefs:9.0.0:*:*:*:*:*:*:* | 9.0.0 | Vulnerable | Dell |
| cpe:2.3:o:dell:emc_powerscale_onefs:9.1.0:*:*:*:*:*:*:* | 9.1.0 | Vulnerable | Dell |
- cpe:2.3:o:dell:emc_powerscale_onefs:8.1.0:*:*:*:*:*:*:* Versions 8.1.0 Vulnerable ·Dell
- cpe:2.3:o:dell:emc_powerscale_onefs:8.1.1:*:*:*:*:*:*:* Versions 8.1.1 Vulnerable ·Dell
- cpe:2.3:o:dell:emc_powerscale_onefs:8.1.2:*:*:*:*:*:*:* Versions 8.1.2 Vulnerable ·Dell
- cpe:2.3:o:dell:emc_powerscale_onefs:8.2.0:*:*:*:*:*:*:* Versions 8.2.0 Vulnerable ·Dell
- cpe:2.3:o:dell:emc_powerscale_onefs:8.2.1:*:*:*:*:*:*:* Versions 8.2.1 Vulnerable ·Dell
- cpe:2.3:o:dell:emc_powerscale_onefs:8.2.2:*:*:*:*:*:*:* Versions 8.2.2 Vulnerable ·Dell
- cpe:2.3:o:dell:emc_powerscale_onefs:9.0.0:*:*:*:*:*:*:* Versions 9.0.0 Vulnerable ·Dell
- cpe:2.3:o:dell:emc_powerscale_onefs:9.1.0:*:*:*:*:*:*:* Versions 9.1.0 Vulnerable ·Dell
Remediation
- Fix · CNA PowerScale OneFS (Dell) Fixed in 8.1.2, 8.2.2, 9.1.0+
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Dell PowerScale OneFS 8.1.2, 8.2.2, 9.1.0+
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2020-16019 Improper input validation in Dell PowerScale OneFSPriority LOW 35
Timeline
- 2026-10-02 Threatist record created from CVE-2020-26191
- 2026-10-03 Alias added: GHSA-qjvv-qc9h-394h
References
More Dell Emc Powerscale Onefs vulnerabilities
- TI-2022-22190 Improper privilege management in Dell PowerScale OneFS CVSS 3.1CRITICAL 9.8
- TI-2022-10097 Dell PowerScale OneFS, versions 8.2.x-9.3.x, contain a predictable seed in pseudo-random… CVSS 3.1CRITICAL 9.8
- TI-2022-06835 Missing brute-force protection in Dell PowerScale OneFS CVSS 3.1CRITICAL 9.8
- TI-2021-04595 Improper authentication in Dell PowerScale OneFS CVSS 3.1CRITICAL 9.8
- TI-2022-22189 Improper certificate validation in Dell PowerScale OneFS CVSS 3.1CRITICAL 9.8
- TI-2022-15270 Insufficiently protected credentials in Dell PowerScale OneFS CVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-26191 · CVE Program
- CVE-2020-26191 · NVD
- FIRST EPSS
- GHSA-qjvv-qc9h-394h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences