An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before…
Priority HIGH 78CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before 5.0.3. A SQL injection vulnerability was discovered in how phpMyAdmin processes SQL statements in the search feature. An attacker could use this flaw to inject malicious SQL in to a query.
Why it matters now
EPSS 0.63702 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed phpmyadmin/phpmyadmin (Packagist): 4.9.6, 5.0.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpmyadmin/phpmyadmin (Packagist) | 4.9.0 to before 4.9.6 | 4.9.6 | Patch available | GHSA-7ff4-cv53-4cjq |
| — | phpmyadmin/phpmyadmin (Packagist) | 5.0.0 to before 5.0.3 | 5.0.3 | Patch available | GHSA-7ff4-cv53-4cjq |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 4.9.0 to before 4.9.6 Fixed in 4.9.6 Patch available GHSA-7ff4-cv53-4cjq
- phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 5.0.0 to before 5.0.3 Fixed in 5.0.3 Patch available GHSA-7ff4-cv53-4cjq
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* | 4.9.0 to before 4.9.6; 5.0.0 to before 5.0.3 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:opensuse:backports_sle:15.0:-:*:*:*:*:*:* | 15.0 | Vulnerable | openSUSE |
| cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* | 15.0 sp1 | Vulnerable | openSUSE |
| cpe:2.3:a:opensuse:backports_sle:15.0:sp2:*:*:*:*:*:* | 15.0 sp2 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* | 15.2 | Vulnerable | openSUSE |
| cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* | 31 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* | 32 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* | 33 | Vulnerable | Fedoraproject |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* Versions 4.9.0 to before 4.9.6; 5.0.0 to before 5.0.3 Vulnerable ·phpMyAdmin
- cpe:2.3:a:opensuse:backports_sle:15.0:-:*:*:*:*:*:* Versions 15.0 Vulnerable ·openSUSE
- cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* Versions 15.0 sp1 Vulnerable ·openSUSE
- cpe:2.3:a:opensuse:backports_sle:15.0:sp2:*:*:*:*:*:* Versions 15.0 sp2 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* Versions 15.2 Vulnerable ·openSUSE
- cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-7ff4-cv53-4cjq phpmyadmin/phpmyadmin (Packagist) Fixed in 4.9.6 Advisory →
- Fix · GHSA-7ff4-cv53-4cjq phpmyadmin/phpmyadmin (Packagist) Fixed in 5.0.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-26935
- 2026-10-03 Alias added: GHSA-7ff4-cv53-4cjq
References
Advisory 8
Other 6
- https://github.com/FriendsOfPHP/security-advisories/blob/master/phpmyadmin/phpmyadmin/CVE-2020-26935.yaml
- https://github.com/phpmyadmin/composer
- https://lists.fedoraproject.org/archives/list/[email protected]/message/FHST4E5IJG7IKZTTW3R6MEZPVHJZ472K
- https://lists.fedoraproject.org/archives/list/[email protected]/message/PXK37YEHSDYCIPQSYEMN2OFTP2ZLM7DO
- https://lists.fedoraproject.org/archives/list/[email protected]/message/TNLGHVDNAEZEGRTUESSSQFM7MZTHIDQ5
- https://www.phpmyadmin.net/security/PMASA-2020-6
Sources
- CVE-2020-26935 · CVE Program
- CVE-2020-26935 · NVD
- FIRST EPSS
- GHSA-7ff4-cv53-4cjq · GitHub Advisory Database · CC BY 4.0
- CVE-2020-26935 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences