aptdaemon performed policykit permissions checks too late
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-862.
Summary
Aptdaemon performed policykit checks after interacting with potentially untrusted files with elevated privileges. This affected versions prior to 1.1.1+bzr982-0ubuntu34.1, 1.1.1+bzr982-0ubuntu32.3, 1.1.1+bzr982-0ubuntu19.5, 1.1.1+bzr982-0ubuntu14.5.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Canonical | aptdaemon | 1.1.1+bzr982-0ubuntu14 to before 1.1.1+bzr982-0ubuntu14.5; 1.1.1+bzr982-0ubuntu19 to before 1.1.1+bzr982-0ubuntu19.5; 1.1.1+bzr982-0ubuntu32 to before 1.1.1+bzr982-0ubuntu32.3; 1.1.1+bzr982-0ubuntu34 to before 1.1.1+bzr982-0ubuntu34.1 | 1.1.1+bzr982-0ubuntu14.5, 1.1.1+bzr982-0ubuntu19.5, 1.1.1+bzr982-0ubuntu32.3, 1.1.1+bzr982-0ubuntu34.1 | Patch available | CNA |
- aptdaemon VendorCanonical Affected 1.1.1+bzr982-0ubuntu14 to before 1.1.1+bzr982-0ubuntu14.5; 1.1.1+bzr982-0ubuntu19 to before 1.1.1+bzr982-0ubuntu19.5; 1.1.1+bzr982-0ubuntu32 to before 1.1.1+bzr982-0ubuntu32.3; 1.1.1+bzr982-0ubuntu34 to before 1.1.1+bzr982-0ubuntu34.1 Fixed in 1.1.1+bzr982-0ubuntu14.5, 1.1.1+bzr982-0ubuntu19.5, 1.1.1+bzr982-0ubuntu32.3, 1.1.1+bzr982-0ubuntu34.1 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* | 20.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:20.10:*:*:*:*:*:*:* | 20.10 | Vulnerable | Canonical |
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* Versions 20.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:20.10:*:*:*:*:*:*:* Versions 20.10 Vulnerable ·Canonical
Remediation
- Fix · CNA aptdaemon (Canonical) Fixed in 1.1.1+bzr982-0ubuntu14.5, 1.1.1+bzr982-0ubuntu19.5, 1.1.1+bzr982-0ubuntu32.3, 1.1.1+bzr982-0ubuntu34.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Canonical aptdaemon 1.1.1+bzr982-0ubuntu14.5, 1.1.1+bzr982-0ubuntu19.5 and 2 more versions
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2020-12687 Aptdaemon error messages disclosed file existence to unprivileged users via dbus propertiesPriority LOW 18
Timeline
- 2026-10-02 Threatist record created from CVE-2020-27349
- 2026-10-03 Alias added: GHSA-qxjq-5hf8-7hff
References
More Canonical Ubuntu Linux vulnerabilities
- TI-2020-09349 An issue was discovered in SaltStack Salt before 2019.2.4 and 3000 before 3000.2. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-05854 smtp_mailaddr in smtp_session.c in OpenSMTPD 6.6, as used in OpenBSD 6.6 and other… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-01431 Netlogon Elevation of Privilege Vulnerability KEVCVSS 3.1CRITICAL 10.0
- TI-2019-12627 Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than… KEVCVSS 3.1CRITICAL 9.8
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-07471 OS command injection in exim KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-27349 · CVE Program
- CVE-2020-27349 · NVD
- FIRST EPSS
- GHSA-qxjq-5hf8-7hff · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences