apt integer wraparound
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
APT had several integer overflows and underflows while parsing .deb packages, aka GHSL-2020-168 GHSL-2020-169, in files apt-pkg/contrib/extracttar.cc, apt-pkg/deb/debfile.cc, and apt-pkg/contrib/arfile.cc. This issue affects: apt 1.2.32ubuntu0 versions prior to 1.2.32ubuntu0.2; 1.6.12ubuntu0 versions prior to 1.6.12ubuntu0.2; 2.0.2ubuntu0 versions prior to 2.0.2ubuntu0.2; 2.1.10ubuntu0 versions prior to 2.1.10ubuntu0.1;
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Canonical | apt | 1.2.32ubuntu0 to before 1.2.32ubuntu0.2; 1.6.12ubuntu0 to before 1.6.12ubuntu0.2; 2.0.2ubuntu0 to before 2.0.2ubuntu0.2; 2.1.10ubuntu0 to before 2.1.10ubuntu0.1 | 1.2.32ubuntu0.2, 1.6.12ubuntu0.2, 2.0.2ubuntu0.2, 2.1.10ubuntu0.1 | Patch available | CNA |
- apt VendorCanonical Affected 1.2.32ubuntu0 to before 1.2.32ubuntu0.2; 1.6.12ubuntu0 to before 1.6.12ubuntu0.2; 2.0.2ubuntu0 to before 2.0.2ubuntu0.2; 2.1.10ubuntu0 to before 2.1.10ubuntu0.1 Fixed in 1.2.32ubuntu0.2, 1.6.12ubuntu0.2, 2.0.2ubuntu0.2, 2.1.10ubuntu0.1 Patch available CNA
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* | 1.2.32ubuntu0 to before 1.2.32ubuntu0.2 | Vulnerable | Debian |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Running on | Canonical |
| cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* | 1.6.12ubuntu0 to before 1.6.12ubuntu0.2 | Vulnerable | Debian |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Running on | Canonical |
| cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* | 2.0.2ubuntu0 to before 2.0.2ubuntu0.2 | Vulnerable | Debian |
| cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* | 20.04 | Running on | Canonical |
| cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* | 2.1.10ubuntu0 to before 2.1.10ubuntu0.2 | Vulnerable | Debian |
| cpe:2.3:o:canonical:ubuntu_linux:20.10:*:*:*:*:*:*:* | 20.10 | Running on | Canonical |
| cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* | before 1.8.2.2 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Running on | Debian |
- cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* Versions 1.2.32ubuntu0 to before 1.2.32ubuntu0.2 Vulnerable ·Debian
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Running on ·Canonical
- cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* Versions 1.6.12ubuntu0 to before 1.6.12ubuntu0.2 Vulnerable ·Debian
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Running on ·Canonical
- cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* Versions 2.0.2ubuntu0 to before 2.0.2ubuntu0.2 Vulnerable ·Debian
- cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* Versions 20.04 Running on ·Canonical
- cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* Versions 2.1.10ubuntu0 to before 2.1.10ubuntu0.2 Vulnerable ·Debian
- cpe:2.3:o:canonical:ubuntu_linux:20.10:*:*:*:*:*:*:* Versions 20.10 Running on ·Canonical
- cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* Versions before 1.8.2.2 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Running on ·Debian
Remediation
- Fix · CNA apt (Canonical) Fixed in 1.2.32ubuntu0.2, 1.6.12ubuntu0.2, 2.0.2ubuntu0.2, 2.1.10ubuntu0.1
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-27350
- 2026-10-03 Alias added: GHSA-j2wg-wfjw-m5cq
References
More Canonical vulnerabilities
- TI-2020-09349 An issue was discovered in SaltStack Salt before 2019.2.4 and 3000 before 3000.2. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-05854 smtp_mailaddr in smtp_session.c in OpenSMTPD 6.6, as used in OpenBSD 6.6 and other… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-01431 Netlogon Elevation of Privilege Vulnerability KEVCVSS 3.1CRITICAL 10.0
- TI-2019-12627 Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than… KEVCVSS 3.1CRITICAL 9.8
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-07471 OS command injection in exim KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-27350 · CVE Program
- CVE-2020-27350 · NVD
- FIRST EPSS
- GHSA-j2wg-wfjw-m5cq · GitHub Advisory Database · CC BY 4.0
- CVE-2020-27350 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences