Various memory and file descriptor leaks in apt-python
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-772.
Summary
Various memory and file descriptor leaks were found in apt-python files python/arfile.cc, python/tag.cc, python/tarfile.cc, aka GHSL-2020-170. This issue affects: python-apt 1.1.0~beta1 versions prior to 1.1.0~beta1ubuntu0.16.04.10; 1.6.5ubuntu0 versions prior to 1.6.5ubuntu0.4; 2.0.0ubuntu0 versions prior to 2.0.0ubuntu0.20.04.2; 2.1.3ubuntu1 versions prior to 2.1.3ubuntu1.1;
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Canonical | python-apt | 1.1.0~beta1 to before 1.1.0~beta1ubuntu0.16.04.10; 1.6.5ubuntu0 to before 1.6.5ubuntu0.4; 2.0.0ubuntu0 to before 2.0.0ubuntu0.20.04.2; 2.1.3ubuntu1 to before 2.1.3ubuntu1.1 | 1.1.0~beta1ubuntu0.16.04.10, 1.6.5ubuntu0.4, 2.0.0ubuntu0.20.04.2, 2.1.3ubuntu1.1 | Patch available | CNA |
- python-apt VendorCanonical Affected 1.1.0~beta1 to before 1.1.0~beta1ubuntu0.16.04.10; 1.6.5ubuntu0 to before 1.6.5ubuntu0.4; 2.0.0ubuntu0 to before 2.0.0ubuntu0.20.04.2; 2.1.3ubuntu1 to before 2.1.3ubuntu1.1 Fixed in 1.1.0~beta1ubuntu0.16.04.10, 1.6.5ubuntu0.4, 2.0.0ubuntu0.20.04.2, 2.1.3ubuntu1.1 Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* | 1.1.0\~beta1 to before 1.1.0\~beta1ubuntu0.16.04.10 | Vulnerable | Debian |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Running on | Canonical |
| cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* | 1.6.5ubuntu0 to before 1.6.5ubuntu0.4 | Vulnerable | Debian |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Running on | Canonical |
| cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* | 2.0.0ubuntu0 to before 2.0.0ubuntu0.20.04.2 | Vulnerable | Debian |
| cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* | 20.04 | Running on | Canonical |
| cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* | 2.1.3ubuntu1 to before 2.1.30ubuntu1.1 | Vulnerable | Debian |
| cpe:2.3:o:canonical:ubuntu_linux:20.10:*:*:*:*:*:*:* | 20.10 | Running on | Canonical |
| cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* | before 1.8.4.2 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Running on | Debian |
- cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* Versions 1.1.0\~beta1 to before 1.1.0\~beta1ubuntu0.16.04.10 Vulnerable ·Debian
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Running on ·Canonical
- cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* Versions 1.6.5ubuntu0 to before 1.6.5ubuntu0.4 Vulnerable ·Debian
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Running on ·Canonical
- cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* Versions 2.0.0ubuntu0 to before 2.0.0ubuntu0.20.04.2 Vulnerable ·Debian
- cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* Versions 20.04 Running on ·Canonical
- cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* Versions 2.1.3ubuntu1 to before 2.1.30ubuntu1.1 Vulnerable ·Debian
- cpe:2.3:o:canonical:ubuntu_linux:20.10:*:*:*:*:*:*:* Versions 20.10 Running on ·Canonical
- cpe:2.3:a:debian:advanced_package_tool:*:*:*:*:*:*:*:* Versions before 1.8.4.2 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Running on ·Debian
Remediation
- Fix · CNA python-apt (Canonical) Fixed in 1.1.0~beta1ubuntu0.16.04.10, 1.6.5ubuntu0.4, 2.0.0ubuntu0.20.04.2, 2.1.3ubuntu1.1
Timeline
- 2026-10-02 Threatist record created from CVE-2020-27351
- 2026-10-03 Alias added: GHSA-mfw3-hgv3-pg44
References
More Canonical vulnerabilities
- TI-2020-09349 An issue was discovered in SaltStack Salt before 2019.2.4 and 3000 before 3000.2. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-05854 smtp_mailaddr in smtp_session.c in OpenSMTPD 6.6, as used in OpenBSD 6.6 and other… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-01431 Netlogon Elevation of Privilege Vulnerability KEVCVSS 3.1CRITICAL 10.0
- TI-2019-12627 Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than… KEVCVSS 3.1CRITICAL 9.8
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-07471 OS command injection in exim KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-27351 · CVE Program
- CVE-2020-27351 · NVD
- FIRST EPSS
- GHSA-mfw3-hgv3-pg44 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences