A stored Cross-Site Scripting (XSS) vulnerability in forms import feature in Rocketgenius…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A stored Cross-Site Scripting (XSS) vulnerability in forms import feature in Rocketgenius Gravity Forms before 2.4.21 allows remote attackers to inject arbitrary web script or HTML via the import of a GF form. This code is interpreted by users in a privileged role (Administrator, Editor, etc.).
Why it matters now
EPSS 0.00806 57th percentileScored 2026-11-07
Fix Fixed wp-premium/gravityforms (Packagist): 2.4.21
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | wp-premium/gravityforms (Packagist) | 2.4 to before 2.4.21 | 2.4.21 | Patch available | GHSA-wmh7-782f-xfw5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- wp-premium/gravityforms (Packagist) Vendor— Affected 2.4 to before 2.4.21 Fixed in 2.4.21 Patch available GHSA-wmh7-782f-xfw5
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rocketgenius:gravityforms:*:*:*:*:*:wordpress:*:* | before 2.4.21 | Vulnerable | RocketGenius |
- cpe:2.3:a:rocketgenius:gravityforms:*:*:*:*:*:wordpress:*:* Versions before 2.4.21 Vulnerable ·RocketGenius
Remediation
- Fix · GHSA-wmh7-782f-xfw5 wp-premium/gravityforms (Packagist) Fixed in 2.4.21 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-27850
- 2026-10-03 Alias added: GHSA-wmh7-782f-xfw5
References
More RocketGenius Gravityforms vulnerabilities
- TI-2020-10759 common.php in the Gravity Forms plugin before 2.4.9 for WordPress can leak hashed… CVSS 3.1HIGH 7.5
- TI-2020-16921 A stored Cross-Site Scripting (XSS) vulnerability in the survey feature in Rocketgenius… CVSS 3.1MEDIUM 5.4
- TI-2020-16920 Multiple stored HTML injection vulnerabilities in the "poll" and "quiz" features in an… CVSS 3.1MEDIUM 5.4
Sources
- CVE-2020-27850 · CVE Program
- CVE-2020-27850 · NVD
- FIRST EPSS
- GHSA-wmh7-782f-xfw5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences