ThinkAdmin version v1 v6 has a stored XSS vulnerability which allows remote attackers to…
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
ThinkAdmin version v1 v6 has a stored XSS vulnerability which allows remote attackers to inject an arbitrary web script or HTML.
Why it matters now
EPSS 0.01026 63rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed zoujingli/thinkadmin (Packagist): 6.0.22
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | zoujingli/thinkadmin (Packagist) | before 6.0.22 | 6.0.22 | Patch available | GHSA-v47f-vp3p-5j6h |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- zoujingli/thinkadmin (Packagist) Vendor— Affected before 6.0.22 Fixed in 6.0.22 Patch available GHSA-v47f-vp3p-5j6h
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:thinkadmin:thinkadmin:1.0:*:*:*:*:*:*:* | 1.0 | Vulnerable | Thinkadmin |
| cpe:2.3:a:thinkadmin:thinkadmin:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Thinkadmin |
- cpe:2.3:a:thinkadmin:thinkadmin:1.0:*:*:*:*:*:*:* Versions 1.0 Vulnerable ·Thinkadmin
- cpe:2.3:a:thinkadmin:thinkadmin:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Thinkadmin
Remediation
- Fix · GHSA-v47f-vp3p-5j6h zoujingli/thinkadmin (Packagist) Fixed in 6.0.22 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-29315
- 2026-10-03 Alias added: GHSA-v47f-vp3p-5j6h
References
More Thinkadmin vulnerabilities
- TI-2023-26702 An issue in the component /admin/api.plugs/script of ThinkAdmin v6.1.53 allows attackers… CVSS 3.1HIGH 8.8
- TI-2020-15591 ThinkAdmin v6 is affected by a directory traversal vulnerability. CVSS 3.1HIGH 7.5
- TI-2023-17404 An arbitrary file upload vulnerability in the component /api/upload.php of ThinkAdmin v6… CVSS 3.1MEDIUM 6.1
- TI-2020-14629 An insecure unserialize vulnerability was discovered in ThinkAdmin versions 4.x through… CVSS 3.1CRITICAL 9.8
- TI-2019-08235 application\admin\controller\User.php in ThinkAdmin V4.0 does not prevent continued use… CVSS 3.0CRITICAL 9.8
- TI-2023-26703 An arbitrary file upload vulnerability in the component /admin/api.upload/file of… CVSS 3.1HIGH 8.8
Sources
- CVE-2020-29315 · CVE Program
- CVE-2020-29315 · NVD
- FIRST EPSS
- GHSA-v47f-vp3p-5j6h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences