Cross-site scripting in Dell Wyse Management Suite
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Dell Wyse Management Suite versions prior to 3.1 contain a stored cross-site scripting vulnerability. A remote authenticated malicious user with high privileges could exploit this vulnerability to store malicious HTML or JavaScript code while creating the Enduser. When victim users access the submitted data through their browsers, the malicious code gets executed by the web browser in the context of the vulnerable application.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA Wyse Management Suite (Dell) Fixed in 3.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Dell Wyse Management Suite 3.1
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2020-17719 Open redirect in Dell Wyse Management SuitePriority LOW 29
- TI-2020-17718 Cross-site scripting in Dell Wyse Management SuitePriority LOW 26
Timeline
- 2026-10-02 Threatist record created from CVE-2020-29496
- 2026-10-03 Alias added: GHSA-hc8f-9595-gg78
References
More Dell Wyse Management Suite vulnerabilities
- TI-2026-56104 Unrestricted file upload in Dell Wyse Management Suite CVSS 3.1CRITICAL 9.8
- TI-2026-56103 Unrestricted file upload in Dell Wyse Management Suite CVSS 3.1CRITICAL 9.8
- TI-2026-56100 Unrestricted file upload in Dell Wyse Management Suite CVSS 3.1CRITICAL 9.8
- TI-2026-29748 Dell Wyse Management Suite, versions prior to WMS 5.5 HF1, contain an Acceptance of… CVSS 3.1CRITICAL 9.8
- TI-2026-56102 Missing authentication in Dell Wyse Management Suite CVSS 3.1CRITICAL 9.1
- TI-2021-14699 Deserialization of untrusted data in Dell Wyse Management Suite CVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-29496 · CVE Program
- CVE-2020-29496 · NVD
- FIRST EPSS
- GHSA-hc8f-9595-gg78 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences