Mautic before 3.2.4 is affected by stored XSS.
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Mautic before 3.2.4 is affected by stored XSS. An attacker with access to Social Monitoring, an application feature, could attack other users, including administrators. For example, an attacker could load an externally drafted JavaScript file that would allow them to eventually perform actions on the target user’s behalf, including changing the user’s password or email address or changing the attacker’s user role from a low-privileged user to an administrator account.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mautic/core (Packagist) | before 3.2.4 | 3.2.4 | Patch available | GHSA-3px5-wjh3-9x6r |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mautic/core (Packagist) Vendor— Affected before 3.2.4 Fixed in 3.2.4 Patch available GHSA-3px5-wjh3-9x6r
Remediation
- Fix · GHSA-3px5-wjh3-9x6r mautic/core (Packagist) Fixed in 3.2.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-35129
- 2026-10-03 Alias added: GHSA-3px5-wjh3-9x6r
References
More Mautic vulnerabilities
- TI-2018-05847 Mautic before 2.13.0 allows CSV injection. CVSS 3.0CRITICAL 9.8
- TI-2017-14698 Mautic versions 2.0.0 - 2.11.0 with a SSO plugin installed could allow a disabled user to… CVSS 3.0HIGH 8.1
- TI-2018-07222 An issue was discovered in Mautic 1.x and 2.x before 2.13.0. CVSS 3.0HIGH 7.5
- TI-2017-14388 Mautic 2.6.1 and earlier fails to set flags on session cookies CVSS 3.0HIGH 7.5
- TI-2017-14699 Mautic versions 1.0.0 - 2.11.0 are vulnerable to allowing any authorized Mautic user… CVSS 3.0MEDIUM 6.5
- TI-2018-05838 Mautic before v2.13.0 has stored XSS via a theme config file. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2020-35129 · CVE Program
- CVE-2020-35129 · NVD
- FIRST EPSS
- GHSA-3px5-wjh3-9x6r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences