GJSON <1.6.5 allows attackers to cause a denial of service (remote) via crafted JSON.
Priority LOW 37CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
GJSON <1.6.5 allows attackers to cause a denial of service (remote) via crafted JSON.
Why it matters now
EPSS 0.01843 79th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed github.com/tidwall/gjson (Go): 1.6.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/tidwall/gjson (Go) | before 1.6.5 | 1.6.5 | Patch available | GHSA-wjm3-fq3r-5x46 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/tidwall/gjson (Go) Vendor— Affected before 1.6.5 Fixed in 1.6.5 Patch available GHSA-wjm3-fq3r-5x46
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gjson_project:gjson:*:*:*:*:*:*:*:* | before 1.6.5 | Vulnerable | Gjson Project |
- cpe:2.3:a:gjson_project:gjson:*:*:*:*:*:*:*:* Versions before 1.6.5 Vulnerable ·Gjson Project
Remediation
- Fix · GHSA-wjm3-fq3r-5x46 github.com/tidwall/gjson (Go) Fixed in 1.6.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-36066
- 2026-10-03 Alias added: GHSA-wjm3-fq3r-5x46
References
Other 5
More Gjson Project Gjson vulnerabilities
- TI-2021-19000 GJSON before 1.9.3 allows a ReDoS (regular expression denial of service) attack. CVSS 3.1HIGH 7.5
- TI-2020-18436 GJSON <=v1.6.5 allows attackers to cause a denial of service (panic: runtime error: slice… CVSS 3.1HIGH 7.5
- TI-2020-17961 GJSON before 1.6.4 allows attackers to cause a denial of service via crafted JSON. CVSS 3.1HIGH 7.5
Sources
- CVE-2020-36066 · CVE Program
- CVE-2020-36066 · NVD
- FIRST EPSS
- GHSA-wjm3-fq3r-5x46 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences