GJSON <=v1.6.5 allows attackers to cause a denial of service (panic: runtime error: slice…
Priority LOW 36CWE-129Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-129 and the CVSS impact.
Summary
GJSON <=v1.6.5 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a crafted GET call.
Why it matters now
EPSS 0.01445 73rd percentileScored 2026-11-07
Fix Fixed github.com/tidwall/gjson (Go): 1.6.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/tidwall/gjson (Go) | before 1.6.6 | 1.6.6 | Patch available | GHSA-p64j-r5f4-pwwx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/tidwall/gjson (Go) Vendor— Affected before 1.6.6 Fixed in 1.6.6 Patch available GHSA-p64j-r5f4-pwwx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gjson_project:gjson:*:*:*:*:*:*:*:* | up to 1.6.5 | Vulnerable | Gjson Project |
- cpe:2.3:a:gjson_project:gjson:*:*:*:*:*:*:*:* Versions up to 1.6.5 Vulnerable ·Gjson Project
Remediation
- Fix · GHSA-p64j-r5f4-pwwx github.com/tidwall/gjson (Go) Fixed in 1.6.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-36067
- 2026-10-03 Alias added: GHSA-p64j-r5f4-pwwx
References
More Gjson Project Gjson vulnerabilities
- TI-2021-19000 GJSON before 1.9.3 allows a ReDoS (regular expression denial of service) attack. CVSS 3.1HIGH 7.5
- TI-2020-18435 GJSON <1.6.5 allows attackers to cause a denial of service (remote) via crafted JSON. CVSS 3.1HIGH 7.5
- TI-2020-17961 GJSON before 1.6.4 allows attackers to cause a denial of service via crafted JSON. CVSS 3.1HIGH 7.5
Sources
- CVE-2020-36067 · CVE Program
- CVE-2020-36067 · NVD
- FIRST EPSS
- GHSA-p64j-r5f4-pwwx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences