PHPMailer 6.1.8 through 6.4.0 allows object injection through Phar Deserialization via…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
PHPMailer 6.1.8 through 6.4.0 allows object injection through Phar Deserialization via addAttachment with a UNC pathname. NOTE: this is similar to CVE-2018-19296, but arose because 6.1.8 fixed a functionality problem in which UNC pathnames were always considered unreadable by PHPMailer, even in safe contexts. As an unintended side effect, this fix eliminated the code that blocked addAttachment exploitation.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpmailer/phpmailer (Packagist) | 6.1.8 to before 6.4.1 | 6.4.1 | Patch available | GHSA-m298-fh5c-jc66 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpmailer/phpmailer (Packagist) Vendor— Affected 6.1.8 to before 6.4.1 Fixed in 6.4.1 Patch available GHSA-m298-fh5c-jc66
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpmailer_project:phpmailer:*:*:*:*:*:*:*:* | 6.1.8 – 6.4.0 | Vulnerable | Phpmailer Project |
| cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* | 3.7 to before 3.7.36; 3.8 to before 3.8.36; 3.9 to before 3.9.34; 4.0 to before 4.0.33; 4.1 to before 4.1.33; 4.2 to before 4.2.30; 4.3 to before 4.3.26; 4.4 to before 4.4.25; 4.5 to before 4.5.24; 4.6 to before 4.6.21; 4.7 to before 4.7.21; 4.8 to before 4.8.17; 4.9 to before 4.9.18; 5.0 to before 5.0.13; 5.1 to before 5.1.10; 5.2 to before 5.2.11; 5.3 to before 5.3.8; 5.4 to before 5.4.6; 5.5 to before 5.5.5; 5.6 to before 5.6.4; 5.7 to before 5.7.2 | Vulnerable | WordPress |
- cpe:2.3:a:phpmailer_project:phpmailer:*:*:*:*:*:*:*:* Versions 6.1.8 – 6.4.0 Vulnerable ·Phpmailer Project
- cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* Versions 3.7 to before 3.7.36; 3.8 to before 3.8.36; 3.9 to before 3.9.34; 4.0 to before 4.0.33; 4.1 to before 4.1.33; 4.2 to before 4.2.30; 4.3 to before 4.3.26; 4.4 to before 4.4.25; 4.5 to before 4.5.24; 4.6 to before 4.6.21; 4.7 to before 4.7.21; 4.8 to before 4.8.17; 4.9 to before 4.9.18; 5.0 to before 5.0.13; 5.1 to before 5.1.10; 5.2 to before 5.2.11; 5.3 to before 5.3.8; 5.4 to before 5.4.6; 5.5 to before 5.5.5; 5.6 to before 5.6.4; 5.7 to before 5.7.2 Vulnerable ·WordPress
Remediation
- Fix · GHSA-m298-fh5c-jc66 phpmailer/phpmailer (Packagist) Fixed in 6.4.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-36326
- 2026-10-03 Alias added: GHSA-m298-fh5c-jc66
References
Advisory 3
Other 6
- https://github.com/PHPMailer/PHPMailer/security/advisories/GHSA-m298-fh5c-jc66
- https://github.com/FriendsOfPHP/security-advisories/blob/master/phpmailer/phpmailer/CVE-2020-36326.yaml
- https://github.com/PHPMailer/PHPMailer
- https://github.com/PHPMailer/PHPMailer/releases/tag/v6.4.1
- https://lists.fedoraproject.org/archives/list/[email protected]/message/3B5WDPGUFNPG4NAZ6G4BZX43BKLAVA5B
- https://lists.fedoraproject.org/archives/list/[email protected]/message/KPU66INRFY5BQ3ESVPRUXJR4DXQAFJVT
Sources
- CVE-2020-36326 · CVE Program
- CVE-2020-36326 · NVD
- FIRST EPSS
- GHSA-m298-fh5c-jc66 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-36326 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences