Spectra < 1.15.0 - Contributor+ Stored Cross-Side Scripting
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Spectra WordPress plugin before 1.15.0 does not sanitize user input as it reaches its style HTML attribute, allowing contributors to conduct stored XSS attacks via the plugin's Gutenberg blocks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00507 43rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Spectra (Unknown): 1.15.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Spectra | before 1.15.0 | 1.15.0 | Patch available | CNA |
- Spectra VendorUnknown Affected before 1.15.0 Fixed in 1.15.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:brainstormforce:spectra:*:*:*:*:*:wordpress:*:* | before 1.15.0 | Vulnerable | Brainstorm Force |
- cpe:2.3:a:brainstormforce:spectra:*:*:*:*:*:wordpress:*:* Versions before 1.15.0 Vulnerable ·Brainstorm Force
Remediation
- Fix · CNA Spectra (Unknown) Fixed in 1.15.0
Timeline
- 2026-10-02 Threatist record created from CVE-2020-36656
- 2026-10-03 Alias added: GHSA-3xxh-w577-324m
References
More Brainstorm Force Spectra vulnerabilities
- TI-2023-09633 Missing authorization in Brainstorm Force Spectra CVSS 3.1CRITICAL 9.8
- TI-2023-09624 Missing authorization in Brainstorm Force Spectra CVSS 3.1HIGH 8.8
- TI-2024-25021 WordPress Spectra plugin <= 2.13.7 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2023-18491 WordPress Spectra plugin <= 2.6.6 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2023-09549 WordPress Spectra – WordPress Gutenberg Blocks plugin <= 2.3.0 - Unauthenticated Email HTML Injection Vulnerability CVSS 3.1MEDIUM 6.1
- TI-2023-18494 WordPress Spectra plugin <= 2.6.6 - Server Side Request Forgery (SSRF) vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2020-36656 · CVE Program
- CVE-2020-36656 · NVD
- FIRST EPSS
- GHSA-3xxh-w577-324m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences