Feed Them Social – Page, Post, Video, and Photo Galleries <= 2.8.6 - Cross-Site Request Forgery Bypass
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
The Feed Them Social – Page, Post, Video, and Photo Galleries plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.8.6. This is due to missing or incorrect nonce validation on the my_fts_fb_load_more() function. This makes it possible for unauthenticated attackers to load feeds via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SlickRemix | Feed Them Social – Social Media Feeds, Video, and Photo Galleries | before 2.8.7 | 2.8.7 | Patch available | CNA |
- Feed Them Social – Social Media Feeds, Video, and Photo Galleries VendorSlickRemix Affected before 2.8.7 Fixed in 2.8.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:slickremix:feed_them_social:*:*:*:*:*:wordpress:*:* | before 2.8.7 | Vulnerable | SlickRemix |
- cpe:2.3:a:slickremix:feed_them_social:*:*:*:*:*:wordpress:*:* Versions before 2.8.7 Vulnerable ·SlickRemix
Remediation
- Fix · CNA Feed Them Social – Social Media Feeds, Video, and Photo Galleries (slickremix) Fixed in 2.8.7
Timeline
- 2026-10-02 Threatist record created from CVE-2020-36739
- 2026-10-03 Alias added: GHSA-qg76-r2j2-x5qp
References
Other 6
- https://blog.nintechnet.com/more-wordpress-plugins-and-themes-vulnerable-to-csrf-attacks/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-3/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-2/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-1/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-5/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-4/
More SlickRemix Feed Them Social vulnerabilities
- TI-2022-02251 Feed Them Social – for Twitter feed, Youtube and more <= 2.9.8.5 - Unauthenticated PHAR Deserialization CVSS 3.1CRITICAL 9.8
- TI-2015-07728 The feed-them-social plugin before 1.7.0 for WordPress has possible shortcode execution… CVSS 3.0CRITICAL 9.8
- TI-2023-10528 WordPress Feed Them Social Plugin <= 3.0.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2022-02199 Feed Them Social < 3.0.1 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2022-02339 Feed Them Social < 3.0.1 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2015-07727 The feed-them-social plugin before 1.7.0 for WordPress has reflected XSS in the Facebook Feeds load more button. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2020-36739 · CVE Program
- CVE-2020-36739 · NVD
- FIRST EPSS
- GHSA-qg76-r2j2-x5qp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences