Read the docs
TI-2020-18909 Aliases CVE-2020-36740GHSA-7835-39wm-qxqw

Radio Buttons for Taxonomies <= 2.0.5 - Cross-Site Request Forgery Bypass

Priority LOW 38CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.

Summary

The Radio Buttons for Taxonomies plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.0.5. This is due to missing or incorrect nonce validation on the save_single_term() function. This makes it possible for unauthenticated attackers to save terms via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00472 41st percentileScored 2026-11-07
Fix Fixed Radio Buttons for Taxonomies (helgatheviking): 2.0.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
helgathevikingRadio Buttons for Taxonomiesbefore 2.0.62.0.6Patch availableCNA
  • Radio Buttons for Taxonomies Vendorhelgatheviking Affected before 2.0.6 Fixed in 2.0.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:radio_buttons_for_taxonomies_project:radio_buttons_for_taxonomies:*:*:*:*:*:wordpress:*:*up to 2.0.5VulnerableRadio Buttons For Taxonomies Project

Remediation

  • Fix · CNA Radio Buttons for Taxonomies (helgatheviking) Fixed in 2.0.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-36740
  2. 2026-10-03 Alias added: GHSA-7835-39wm-qxqw

References

  • TI-2023-15594 WordPress Simple User Listing Plugin <= 1.9.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2026-06599 KIA Subtitle <= 4.0.1 - [Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')] CVSS 3.1MEDIUM 6.4

Sources