OpenNMS Meridian 2016, 2017, 2018 before 2018.1.25, 2019 before 2019.1.16, and 2020…
Priority MEDIUM 43CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
OpenNMS Meridian 2016, 2017, 2018 before 2018.1.25, 2019 before 2019.1.16, and 2020 before 2020.1.5, Horizon 1.2 through 27.0.4, and Newts <1.5.3 has Incorrect Access Control, which allows local and remote code execution using JEXL expressions.
Why it matters now
EPSS 0.02365 83rd percentileScored 2026-11-07
Fix Fixed org.opennms:opennms (Maven): 27.0.4org.opennms.features:org.opennms.features.measurements (Maven): 27.0.4+2 more products
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.opennms:opennms (Maven) | 16.0.0 to before 27.0.4 | 27.0.4 | Patch available | GHSA-c3mp-9vx3-2rvv |
| — | org.opennms.features:org.opennms.features.measurements (Maven) | 16.0.0 to before 27.0.4 | 27.0.4 | Patch available | GHSA-c3mp-9vx3-2rvv |
| — | org.opennms:opennms-provision (Maven) | 16.0.0 to before 27.0.4 | 27.0.4 | Patch available | GHSA-c3mp-9vx3-2rvv |
| — | org.opennms:opennms-util (Maven) | 16.0.0 to before 27.0.4 | 27.0.4 | Patch available | GHSA-c3mp-9vx3-2rvv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.opennms:opennms (Maven) Vendor— Affected 16.0.0 to before 27.0.4 Fixed in 27.0.4 Patch available GHSA-c3mp-9vx3-2rvv
- org.opennms.features:org.opennms.features.measurements (Maven) Vendor— Affected 16.0.0 to before 27.0.4 Fixed in 27.0.4 Patch available GHSA-c3mp-9vx3-2rvv
- org.opennms:opennms-provision (Maven) Vendor— Affected 16.0.0 to before 27.0.4 Fixed in 27.0.4 Patch available GHSA-c3mp-9vx3-2rvv
- org.opennms:opennms-util (Maven) Vendor— Affected 16.0.0 to before 27.0.4 Fixed in 27.0.4 Patch available GHSA-c3mp-9vx3-2rvv
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opennms:horizon:*:*:*:*:*:*:*:* | 16.0.0 – 27.0.3 | Vulnerable | The OpenNMS Group |
| cpe:2.3:a:opennms:meridian:*:*:*:*:*:*:*:* | 2016.1.0 – 2016.1.24; 2017.1.0 – 2017.1.26; 2018.1.0 to before 2018.1.25; 2019.1.0 to before 2019.1.16; 2020.1.0 to before 2020.1.5 | Vulnerable | The OpenNMS Group |
| cpe:2.3:a:opennms:newts:*:*:*:*:*:*:*:* | before 1.5.3 | Vulnerable | The OpenNMS Group |
- cpe:2.3:a:opennms:horizon:*:*:*:*:*:*:*:* Versions 16.0.0 – 27.0.3 Vulnerable ·The OpenNMS Group
- cpe:2.3:a:opennms:meridian:*:*:*:*:*:*:*:* Versions 2016.1.0 – 2016.1.24; 2017.1.0 – 2017.1.26; 2018.1.0 to before 2018.1.25; 2019.1.0 to before 2019.1.16; 2020.1.0 to before 2020.1.5 Vulnerable ·The OpenNMS Group
- cpe:2.3:a:opennms:newts:*:*:*:*:*:*:*:* Versions before 1.5.3 Vulnerable ·The OpenNMS Group
Remediation
- Fix · GHSA-c3mp-9vx3-2rvv org.opennms:opennms (Maven) Fixed in 27.0.4 Advisory →
- Fix · GHSA-c3mp-9vx3-2rvv org.opennms.features:org.opennms.features.measurements (Maven) Fixed in 27.0.4 Advisory →
- Fix · GHSA-c3mp-9vx3-2rvv org.opennms:opennms-provision (Maven) Fixed in 27.0.4 Advisory →
- Fix · GHSA-c3mp-9vx3-2rvv org.opennms:opennms-util (Maven) Fixed in 27.0.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3396
- 2026-10-03 Alias added: GHSA-c3mp-9vx3-2rvv
References
Advisory 3
More The OpenNMS Group Horizon vulnerabilities
- TI-2021-07941 Cross-site request forgery in OpenNMS CVSS 3.1HIGH 8.8
- TI-2021-07943 Cross-site scripting in OpenNMS CVSS 3.1MEDIUM 4.8
- TI-2021-07939 Cross-site scripting in OpenNMS CVSS 3.1MEDIUM 4.8
- TI-2021-07940 Cross-site request forgery in OpenNMS CVSS 3.1MEDIUM 4.3
- TI-2023-00827 ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users CVSS 3.1HIGH 8.2
- TI-2023-21153 Disable BeanShell Interpreter Remote Server Mode CVSS 3.1HIGH 8.8
Sources
- CVE-2021-3396 · CVE Program
- CVE-2021-3396 · NVD
- FIRST EPSS
- GHSA-c3mp-9vx3-2rvv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences