Read the docs
TI-2023-21153 Aliases CVE-2023-40313GHSA-5m5f-qg8r-p9qf

Disable BeanShell Interpreter Remote Server Mode

Priority MEDIUM 41CWE-94Published · Updated

Key facts

Attack vector
Adjacent network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

A BeanShell interpreter in remote server mode runs in OpenMNS Horizon versions earlier than 32.0.2 and in related Meridian versions which could allow arbitrary remote Java code execution. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00783 56th percentileScored 2026-11-07
Fix Fixed Horizon (The OpenNMS Group): 32.0.2org.opennms:opennms-base-assembly (Maven): 32.0.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
The OpenNMS GroupHorizon29.0.4 to before 32.0.232.0.2Patch availableCNA
The OpenNMS GroupMeridian2020.0.0 – 2020.1.37; 2021.0.0 – 2021.1.29; 2022.0.0 – 2022.1.18; 2023.0.0 – 2023.1.5—No fix listedCNA
—org.opennms:opennms-base-assembly (Maven)before 32.0.232.0.2Patch availableGHSA-5m5f-qg8r-p9qf
  • Horizon VendorThe OpenNMS Group Affected 29.0.4 to before 32.0.2 Fixed in 32.0.2 Patch available CNA
  • Meridian VendorThe OpenNMS Group Affected 2020.0.0 – 2020.1.37; 2021.0.0 – 2021.1.29; 2022.0.0 – 2022.1.18; 2023.0.0 – 2023.1.5 Fixed in — No fix listed CNA
  • org.opennms:opennms-base-assembly (Maven) Vendor— Affected before 32.0.2 Fixed in 32.0.2 Patch available GHSA-5m5f-qg8r-p9qf

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:opennms:horizon:*:*:*:*:*:*:*:*before 32.0.2VulnerableThe OpenNMS Group
cpe:2.3:a:opennms:meridian:*:*:*:*:*:*:*:*before 2020.1.38; 2021.1.0 to before 2021.1.30; 2022.1.0 to before 2022.1.19; 2023.1.0 to before 2023.1.6VulnerableThe OpenNMS Group
  • cpe:2.3:a:opennms:horizon:*:*:*:*:*:*:*:* Versions before 32.0.2 Vulnerable ·The OpenNMS Group
  • cpe:2.3:a:opennms:meridian:*:*:*:*:*:*:*:* Versions before 2020.1.38; 2021.1.0 to before 2021.1.30; 2022.1.0 to before 2022.1.19; 2023.1.0 to before 2023.1.6 Vulnerable ·The OpenNMS Group

Remediation

  • Fix · CNA Horizon (The OpenNMS Group) Fixed in 32.0.2
  • Fix · GHSA-5m5f-qg8r-p9qf org.opennms:opennms-base-assembly (Maven) Fixed in 32.0.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-40313
  2. 2026-10-03 Alias added: GHSA-5m5f-qg8r-p9qf

References

  • TI-2021-07941 Cross-site request forgery in OpenNMS CVSS 3.1HIGH 8.8
  • TI-2021-07943 Cross-site scripting in OpenNMS CVSS 3.1MEDIUM 4.8
  • TI-2021-07939 Cross-site scripting in OpenNMS CVSS 3.1MEDIUM 4.8
  • TI-2021-07940 Cross-site request forgery in OpenNMS CVSS 3.1MEDIUM 4.3
  • TI-2021-02366 OpenNMS Meridian 2016, 2017, 2018 before 2018.1.25, 2019 before 2019.1.16, and 2020… CVSS 3.1HIGH 8.8
  • TI-2023-00827 ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users CVSS 3.1HIGH 8.2
See all 21 →

Sources