Improper Input Validation in Bitdefender Endpoint Security Tools for Linux
Priority LOW 31CWE-494Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-494.
Summary
An Improper Input Validation vulnerability in the Product Update feature of Bitdefender Endpoint Security Tools for Linux allows a man-in-the-middle attacker to abuse the DownloadFile function of the Product Update to achieve remote code execution. This issue affects: Bitdefender Endpoint Security Tools for Linux versions prior to 6.2.21.155.
Why it matters now
EPSS 0.0088 59th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Endpoint Security Tools for Linux (Bitdefender): 6.2.21.155
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Bitdefender | Endpoint Security Tools for Linux | before 6.2.21.155 | 6.2.21.155 | Patch available | CNA |
- Endpoint Security Tools for Linux VendorBitdefender Affected before 6.2.21.155 Fixed in 6.2.21.155 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:bitdefender:endpoint_security_tools:*:*:*:*:*:linux:*:* | before 6.2.21.155 | Vulnerable | Bitdefender |
- cpe:2.3:a:bitdefender:endpoint_security_tools:*:*:*:*:*:linux:*:* Versions before 6.2.21.155 Vulnerable ·Bitdefender
Remediation
- Fix · CNA Endpoint Security Tools for Linux (Bitdefender) Fixed in 6.2.21.155
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3485
- 2026-10-03 Alias added: GHSA-wg6r-fv2h-h7xm
References
More Bitdefender Endpoint Security Tools vulnerabilities
- TI-2021-02507 Improper access control in Bitdefender Endpoint Security Tools for Linux CVSS 3.1CRITICAL 10.0
- TI-2025-06435 Local Privilege Escalation via Arbitrary File Operation in Bitdefender Total Security CVSS 4.0HIGH 8.8
- TI-2021-02525 Privilege escalation via SeImpersonatePrivilege CVSS 3.1HIGH 7.8
- TI-2021-02505 Insufficient validation on regular expression in EPPUpdateService config file (VA-9825) CVSS 3.1HIGH 7.5
- TI-2022-00592 Improper Handling of Length Parameter Inconsistency vulnerability in Bitdefender Update Server (VA-10144) CVSS 3.1HIGH 7.5
- TI-2021-03065 Incorrect Permission Assignment for Critical Resource vulnerability in BDReinit.exe (VA-10017) CVSS 3.1HIGH 7.8
Sources
- CVE-2021-3485 · CVE Program
- CVE-2021-3485 · NVD
- FIRST EPSS
- GHSA-wg6r-fv2h-h7xm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences