Certain HP Enterprise LaserJet and PageWide MFPs may be vulnerable to stored cross site scripting (XSS).
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Certain HP Enterprise LaserJet and PageWide MFPs may be vulnerable to stored cross site scripting (XSS).
Why it matters now
EPSS 0.00474 41st percentileScored 2026-11-07
Fix Fixed HP Enterprise LaserJet MFP; HP Enterprise PageWide MFPs; HP Digital Sender: 4.11.2.1, 5.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | HP Enterprise LaserJet MFP; HP Enterprise PageWide MFPs; HP Digital Sender | before 4.11.2.1; before 5.3 | 4.11.2.1, 5.3 | Patch available | CNA |
- HP Enterprise LaserJet MFP; HP Enterprise PageWide MFPs; HP Digital Sender Vendor— Affected before 4.11.2.1; before 5.3 Fixed in 4.11.2.1, 5.3 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:hp:futuresmart_4:*:*:*:*:*:*:*:* | before 4.11.2.1 | Vulnerable | Hewlett Packard Enterprise |
| cpe:2.3:o:hp:futuresmart_5:*:*:*:*:*:*:*:* | before 5.3 | Vulnerable | Hewlett Packard Enterprise |
- cpe:2.3:o:hp:futuresmart_4:*:*:*:*:*:*:*:* Versions before 4.11.2.1 Vulnerable ·Hewlett Packard Enterprise
- cpe:2.3:o:hp:futuresmart_5:*:*:*:*:*:*:*:* Versions before 5.3 Vulnerable ·Hewlett Packard Enterprise
Remediation
- Fix · CNA HP Enterprise LaserJet MFP; HP Enterprise PageWide MFPs; HP Digital Sender Fixed in 4.11.2.1, 5.3
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3662
- 2026-10-03 Alias added: GHSA-x4q2-9q8g-3mmf
References
More Hewlett Packard Enterprise Futuresmart 4 vulnerabilities
- TI-2021-16623 Buffer overflow in HP Enterprise LaserJet; HP LaserJet Managed; HP Enterprise PageWide… CVSS 3.1CRITICAL 9.8
- TI-2019-04500 HP LaserJet, PageWide, OfficeJet Enterprise, and LaserJet Managed Printers have a… CVSS 3.1CRITICAL 9.8
- TI-2025-19449 Out-of-bounds write in Hewlett Packard Enterprise Certain HP LaserJet Pro, HP LaserJet… CVSS 4.0HIGH 8.3
- TI-2019-13633 A potential security vulnerability has been identified for certain HP printers and MFPs… CVSS 3.1HIGH 7.8
- TI-2025-19448 Stack-based buffer overflow in Hewlett Packard Enterprise Certain HP LaserJet Pro, HP… CVSS 4.0MEDIUM 6.3
- TI-2024-00369 Certain HP Enterprise LaserJet, HP LaserJet Managed Printers – Potential Information Disclosure CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-3662 · CVE Program
- CVE-2021-3662 · NVD
- FIRST EPSS
- GHSA-x4q2-9q8g-3mmf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences