Stored Cross-site Scripting (XSS) in sylius/sylius
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
sylius/sylius versions prior to 1.9.10, 1.10.11, and 1.11.2 are vulnerable to stored cross-site scripting (XSS) through SVG files. This vulnerability allows attackers to inject malicious scripts that can be executed in the context of the user's browser.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00256 17th percentileScored 2026-11-07
Fix Fixed sylius/sylius (sylius): 1.9.10, 1.10.11, 1.11.2sylius/sylius (Packagist): 1.9.10, 1.10.11, 1.11.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Sylius | sylius/sylius | before 1.9.10, 1.10.11, 1.11.2 | 1.9.10, 1.10.11, 1.11.2 | Patch available | CNA |
| — | sylius/sylius (Packagist) | before 1.9.10 | 1.9.10 | Patch available | GHSA-hhvr-2q69-4563 |
| — | sylius/sylius (Packagist) | 1.10.0 to before 1.10.11 | 1.10.11 | Patch available | GHSA-hhvr-2q69-4563 |
| — | sylius/sylius (Packagist) | 1.11.0 to before 1.11.2 | 1.11.2 | Patch available | GHSA-hhvr-2q69-4563 |
- sylius/sylius VendorSylius Affected before 1.9.10, 1.10.11, 1.11.2 Fixed in 1.9.10, 1.10.11, 1.11.2 Patch available CNA
- sylius/sylius (Packagist) Vendor— Affected before 1.9.10 Fixed in 1.9.10 Patch available GHSA-hhvr-2q69-4563
- sylius/sylius (Packagist) Vendor— Affected 1.10.0 to before 1.10.11 Fixed in 1.10.11 Patch available GHSA-hhvr-2q69-4563
- sylius/sylius (Packagist) Vendor— Affected 1.11.0 to before 1.11.2 Fixed in 1.11.2 Patch available GHSA-hhvr-2q69-4563
Remediation
- Fix · CNA sylius/sylius (sylius) Fixed in 1.9.10, 1.10.11, 1.11.2
- Fix · GHSA-hhvr-2q69-4563 sylius/sylius (Packagist) Fixed in 1.9.10 Advisory →
- Fix · GHSA-hhvr-2q69-4563 sylius/sylius (Packagist) Fixed in 1.10.11 Advisory →
- Fix · GHSA-hhvr-2q69-4563 sylius/sylius (Packagist) Fixed in 1.11.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3841
- 2026-10-03 Alias added: GHSA-hhvr-2q69-4563
References
More Sylius vulnerabilities
- TI-2026-24374 Sylius is Missing Authorization in API v2 Add Item Endpoint CVSS 4.0MEDIUM 6.9
- TI-2022-08557 Insufficient Session Expiration in Sylius CVSS 3.1HIGH 8.2
- TI-2026-24378 Sylius has a DQL Injection via API Order Filters CVSS 3.1MEDIUM 5.3
- TI-2024-19437 Sylius 1.12.13 is vulnerable to Cross Site Scripting (XSS) via the "Province" field in Address Book. CVSS 3.1MEDIUM 6.4
- TI-2022-08563 Basic Cross-site Scripting and Unrestricted Upload of File with Dangerous Type in Sylius CVSS 3.1MEDIUM 6.1
- TI-2026-24377 Sylius has a Promotion Usage Limit Bypass via Race Condition CVSS 3.1HIGH 8.2
Sources
- CVE-2021-3841 · CVE Program
- CVE-2021-3841 · NVD
- FIRST EPSS
- GHSA-hhvr-2q69-4563 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences